Total Commander 7.50 f*cked up my bluray discs! Please, help or confirm problem!



I use Win 7 x64 and LG BH08LS20 f/w 2.00.

I store some files on multisession BD-Rs and used to operate with them like on a safe read-only place. Like CD or DVD-R. But this UDF is like MountRainer wich I can’t disable!

So simply insert a BD-R wich was burned on Nero, COPY/DELETE or REWRITE some files on it using Total Commander, eject disc, insert it again and Windows will not mount it!
Ok. Thinking new session is incorrect -> Open Nero, put some files on disc, burn new session to make it right.
Now mount disc on Windows and browse files BUT they AREN’T THOSE files! Content seems to be shifted!

I found the reason when tried to mount such discs on Mac OS X.

Mac doesn’t mount them correct until I forcely mount_udf with block of 4 KB -b 4096. The default unit size on discs is 2KB. That’s why Windows can’t mount it or mount incorrect!
But when it mounts under Mac with option ‘-b 4096’ in terminal it is all right.

One good japanese BD-R disc costs about $25 in Moscow. (I bought them a year ago.) Why I shoud buy new discs and rewrite that crap under Mac?!

Is it possible to DISABLE in Total Commander writing on DISCS (CD/DVD/BD) AT ALL?
Or mount UDF only as read-only to keep safe?

P.S. And there no InCD or boolshit drivers on my system.


Author of Total Commander said that TC uses only documented Windows functions to copy files and there can be OS-based conficts or incompatibilities with UDF and I gonna try to install newer UDF drivers to fix the problem.

BD-Rs use UDF 2.60 by the way. So I cannot mount it on Free/OpenBSD, but Mac OSX does.

My system is actually Windows Server 2008 R2 but technically it is the same Win 7 x64.


This is a downloadable update:

Password: #Erq1kh


However it doesn’t help.
Here is one more fix:

And no updates.
They asking to wait for SP1.