Toshiba SD-R5372 - reads OK, no write & no erase

vbimport

#1

Hello. Windows XP Pro SP2 - Athlon 64 3400+, 512 MB RAM, Toshiba R5372 DVD/CD burner. Having a lot of trouble recently with the optical drive not completing a write and not recognizing blank media. It will read and play a commercial DVD and a commercial CD (music). The drive was working fine until recently about 2 weeks ago. Back about 4 months ago, I flashed it to incorporate the latest firmware obtained from the Toshiba web (TU56). Again, after flashing it, it was working fine for a good long time. The basic symptom is: I stick a blank DVD R/W or CD-R or CD-RW in, the drive spins up, the activity light winks about 20 times then it quiets. Go to copy a file in Explorer (IMAPI) and Win reports there’s no disc. Go to write something in Nero and right at the end of the burn, I get “An error has occurred”. Erasing a DVD R/W or CD-R/W with either IMAPI or Nero and it goes through but then insert it back in and try a write and I get the “disk is not empty or is not a writable disk… Insert an empty disk”. Tried three diff brands of media. I do notice that upon inserting a blank, after spin-up the disk icon in Explorer will change from DVD R-W Drive to CD ROM Drive on it’s own.

In looking around, I see in device mgr somehow I have picked up extra Primary and Secondary IDE Channels. I don’t know when this might have occurred. IOW, what I see listed in Device Mgr under “IDE ATA/ATAPI Controllers” is:

Primary IDE Channel
Primary IDE Channel
Secondary IDE Channel
Secondary IDE Channel
Standard Dual Channel PCI IDE Channel Controller
VIA Busmaster IDE Controller

I don’t think this is right and I further believe this causes a “conflict” and thus may be the root of my problem with the optical drive. The hard drive on the primary channel runs OK and seems to be unaffected. Should I work on removing the duplicate Primaries and Secondaries? Question is which ones should be removed/disabled and, of course, how exactly do you do that?

More: In the list above (disregarding the last two for the moment), on the individual Properties panel, the first entry cannot be disabled, but the other three can. I am also concerned that by uninstalling any or all of them, Windows won’t fire off and then I’ll really be sunk. The second and fourth entries do have a “Resources” tab listed, the first and third do not (and therefore you can’t see what IRQ they’re sitting on for example). I have already tried “uninstalling” the first and third entries but they just returned on reboot and this almost messed up everything too with a bunch of rather serious souding PNP error messages about service manager not functioning and device could not be found.

Can I get some opinions on how should I proceed here? I’d like to get my DVD/CD burner back!!! Thanks, folks!


#2

First, use a real burning app, not that imapi crap which doesn’t support dvd media.

Then check the settings for enabled DMA mode.


#3

Thank You Chef. No more IMAPI for me, then, at least for writing purposes. I thought I could at least erase a DVD R/W but now I know not to bother with it. I still should be able to read and write CD R/W disks with it though. I usually use Nero 7.0 Ultra for most all my writing tasks. I do have a few other progs but try to stick with one only.

Now I went and rechecked DMA as you asked. I went to Dev Mgr, right clicked on each of the four IDE “objects” I have there. Each is set to DMA, not PIO. I also went to the Toshiba drive in Dev Mgr and pulled up the Properties sheet looking for some DMA setting at the drive level in Windows. There isn’t one in any of the 5 tabs there that I could find so at this time I assume that DMA is set at the IDE ports. Correct? I am still perplexed by the presence of a duplicate set of IDE ports and am wondering about your thoughts relative to that. My other computer does NOT have the four - just two - which is why I’m puzzled.

BTW I see a few other posts about problems/issues currently going on with the Toshiba product. So I’m not alone here. Hope those folks are watching this thread like I’m watching theirs.

I’ll wait to see if you can suggest the next step. Thanks very much!


#4

When the m$ ide drivers are used, you can find the dma settings in the specific ide channel properties (in 16bit windooze OS’s they were in drive properties).

For erasing/formatting RW media I would suggest DVDinfo - it has proven to be the best tool for that. Using Packet-writing for such media is a nice idea, but onl works reliable in theory. :wink:


#5

OK, I took a look at DVDInfo. It gives you a lot of info on the drive characteristics. It did erase a couple of DVDs. Is there something else I can use it for to diagnose and cure the “no burn” issue?

I’m also still fretting about the doubled set of IDE ports. I wonder if that is correct and if not, could that be the problem? If so, I don’t really know how to get rid of them because they unfortunately keep coming back on reboot.

In reviewing some of the other posts, let me also point out that I had also picked up (somehwere?) the dreaded “ASPI” layer software. Is it possible that that thing is interfering? I don’t want to go and uninstall it without checking with someone more knowledgable first. I see some references to it as a “baddie” and some refs that it is OK. Any opinions there?

Thanks to all who are trying to help out.


#6

On normal IDE ports 2 drives can be connected to, they either have to be jumpered CS/Cable Select then or what is recommended, one as Master and the other as Slave.

ASPI can be an issue, but normally it’s not.

You maybe could try a simulation burn using Nero cd dvd speed or even Nero, or dom some advanced media tests using DVDInfo.