Toshiba SD-M1402 DVD-ROM problem

At least half the time after booting up, the drive’s light flashes a code continuously: 1 long, 1 short. What does this mean? I can’t open the drive door either.

Other times after booting up, it’s fine, with no code and the door opens.

I’ve tried it in two PC’s, one with WinXP, other with 98SE. I’ve tried it as slave, CS, and also by itself on it’s own channel as master.
It’s been this way for at least a year now. Is it broken?

Does anyone have any idea?

Maybe broken.
It is recognized in the bios and devcemanager as what?

AXV CD/DVD-ROM SCSI CdRom Device

lol, this is a virtual drive.

Well then it wasn’t listed at all in dev mgr.

What happens is when it’s working, it’s listed correctly in dev mgr. When it’s not working (which is most often), it’s not listed at all.

So why did you ask this?

Anyone know?

Just trying one last time to see if anyone knows for sure before I throw it in the garbage.

Because when it is not seen in the BIOS then its dead OR wrong connected.
Check the jumpers!