Toshiba Satellite/Optiarc ad-7590a problem (yep another one)

vbimport

#1

Hello computer savvy types! :slight_smile:

I am having a little problem and it seems you have helped people with similar dramas, so thought I would seek help…
<I did search through your forums and found a lot of very helpful info about this install, but nothing pertaining to my particular problem. If I have missed/overlooked something, I apologise in advance!>

I have a Toshiba Satellite P35 (S6292), running WinXP SP2. It had a Mat(shit)a drive :Z which was painfully slow and has restrictive firmware so I purchased an Optiarc AD-7590a drive to replace it.

When I installed the new drive and booted my laptop, device manager recognised the Optiarc drive as still being the Matshita one. I tried to check with Nero Infotool, but it said Optiarc drive failed to install correctly.

To check what the Master/Slave settings were on my original Matshita drive, I reinstalled it and Device Manager and Infotool both said that the drive in the machine was the AD-7590, not the Matshita in the machine??? It now obviously no longer functioned correctly.

I then reinstalled the Sony drive again and the machine recognised the 7590 as the Matshita one again. Huh? :doh:

The Toshiba BIOS is painfully limited and has no auto-detect options, so I really don’t know what to do anymore.
I think I need to:
a) identify the master/slave settings of the Matshita drive {which means it needs to be recognised correctly again}

b) make sure the master/slave settings are correct on the ad-7590 in another machine {hope this doesn’t make the same problems happen on my GF’s Acer laptop!}

c)reinstall the ad-7590 into my Toshiba and put some sweet Liggy goodness into it :bigsmile:

Can anyone pleeeeeez help? Would be much appreciated! :bow:

many thanks for any advice!

Cheers, Jon :flower:


#2

Hi and Welcome!

I would try this:
http://support.microsoft.com/kb/315539 to make all hardware visible in Device manager. Then get rid of all optical drives installed.
Also you may need to uninstall software that has influence on optical drives like virtual drive software, UDF drivers etc.

See if that works.

Also: Make sure you have SP3 and all recent patches installed.

Michael


#3

Hi Michael :slight_smile:

Thanks for the advice!
I have now managed to get the drive recognised - I put the original one in again and scanned for hardware changes in Device Manager. It then updated the info to say the Matshita drive was the one installed (correctly) and when I reinstalled the Sony one it then identified that one as well.

Now all I have to do is get it to work as a DVD DL drive as it is showing in the Nero Infotool as being a 6x read/no burn drive.

So I guess I will be heading down the path of installing it in another machine to change the slave/master settings.
Strange though, I can’t seem to find in the Infotool report where it tells me whether the drive is set to slave or master? (I’m sure someone knows what I am missing here :p)
I shall continue to work on this…

Background info: I continue to run my machine “SP2 no updates”, because it is much, much faster than when I tried SP3. I have no security problems with the machine, so this is the best solution for me :slight_smile:


#4

Hi again :slight_smile:

Just thought I would give a final update and info for any others with similar problems in future.

The G590 Changetool (found here: http://club.myce.com/f86/nec-optiars-ad-7590a-01-master-slave-240107/) worked straight away on my particular machine, well after I took a DVD out of the drive anyway… :stuck_out_tongue:

And Liggy’s advice to change the mode to Reverse ATA was indeed correct for this Toshiba as well. I now have full functionality which I will test out today.

I have flashed the drive 1.05 RPC1 with Binflash and it is operating as it should. Brilliant!

Thanks to this forum and its members, it is really a wealth of information! :bow:


#5

Nice you got it sorted :slight_smile:


#6

So I’m back again…

This is rather strange, but I noticed that I have been having a lot of problems with my laptop freezing since I installed this drive and when I restart the BIOS does not start. I have to leave the machine a day or so before it will work again.

I attempted to boot the machine from the DVD drive, so that I could reload the operating system, and noticed that the BIOS does not recognise the new Sony Optiarc drive ??? so it will not boot from CD.
Additionally, when I checked with the changetool, it said the drive was configured Standard ATA again and even though I can change it successfully each time I use the tool, it does not seem to save the settings after restart.

Would I be right in assuming these problems are all related?
And does anyone know why a Toshiba Satellite P35 might not save the IDE settings to the BIOS etc?

The drive works fine in windows - i have burnt DVDs successfully - but the BIOS doesn’t see it.

Hope someone can help :doh: Thanks!