Toshiba satelite pro a300 turn on with black screen

Hi Everyone:

I’m attempting to repair a Toshiba satellite pro a300 for a friend. When you turn it on all you hear, is the processor fan spinning up and optical drive testing but nothing else no hdd drive activity, no POST, just a black laptop screen.

Initially, the fan will spin up and drive test once but if you turn it off by holding the power button down approx 10 seconds and turn it back on, the fan will stay on.

As a had a spare broken laptop of the model, laying around that I knew everything worked on apart from a BIOS bug that would ask for a start-up password that had been randomly generated by the system itself, is no hope getting past that. So as you can imagine, I haven’t much faith in the laptop models reliability.

I’ve tried with no success.:sad:

  1. new memory modules
  2. new hard drive
  3. a complete laptop strip down, checking all connections
  4. stripping the laptop monitor to check the video connector
  5. replacing the original laptop monitor, to rule out back-light burnout or a bad GPU.

I’m no Noob, but this one has got me, at a loss:confused: and the only conclusion, I can draw is yet another MB has gone south, doesn’t say much for Toshiba

Any Suggestions?

Hi and Welcome!

I am not sure if these laptops have a coin cell battery, but you should have a look at that. Sometimes a bad battery might cause the computer to not boot.

Additional hint: replacing the monitor does not rule out a bad GPU :wink: Out of curiosity: is there an add-on GPU, or does this laptop has integrated VGA?

Michael

Thanks for the help, I had that thought myself about the bad battery but the battery is soldered directly onto the main board and I’m not able to solder fine enough to even attempt replacing it.

The GPU is an add-on not integrated so I was able to eliminate that as being the problem.

I also was using a spare test A300 that got hit by a Randomly Generated Start-up Password BIOS bug, recently but it was out of warranty funny how that always happens for spares or repairs. So I swapped the main-boards, as I knew that one at least boots and it did.

So, I think its either a blown CPU or main-board either pretty fatal.

But if anyone has any other idea, be glad to try them