Toshiba DVD M1212

vbimport

#1

Hi, guys

I got a toshiba dvd rom drive here and am trying to get it working for a mate, The guy who had it first couldnt get it detected on his system at all..

I tried it in an old K6-2 comp and it worked fine as 2nd Master at reading CDs but couldnt read a DVD at all

both were using Win98se

Now im in Win2k and windows detected the DVD-Rom drive without a problem, only problem is it wont read either CD nor DVD

any ideas what the problem could be??

bad attempt at region patching??

its on 2nd slave at the mo also

this is what i get from clonecd

Manufacturer: TOSHIBA
Product: DVD-ROM SD-M1212
Revision: 1R14
Can read CD-R Discs: Yes
Can read CD-RW Discs: Yes
Can read DVD Discs: Yes
Can read MultiSession Discs: Yes
Can read Digital Audio Discs: Yes
Digital Audio Data is accurate: Yes

Cheers

Dom


#2

why did you accept a drive that didn’t work…perhaps it is broken


#3

It could be broken, but it didnt cost me anything :slight_smile:

and i am ‘trying to fix it for a mate’.

I flashed to 1r22 and all went well (in pure DOS mode, no cd-rom support).

Started up Win2k and still nothing…

ah well

didnt cost me owt


#4

a pity


#5

I realize this subject is old, but I just found the thread while troubleshooting my DVD drive. I have the same issue… Toshiba M1212 will not work in my Win2K box. I can read CD’s, CDR’s, DVD’s, etc., but I cannot get the drive to act on the data on the disc. It won’t play music files, read text files, etc.

I know the drive works as I put it in an old Compaq box at work and it played the DVD disc like a champ.

I have an ASUS A7v motherboard and an ATI All-In-Wonder PRO video card. They only clue I’ve gotten so far is from the Power-DVD diagnostics app:

vts_01_0.ifo : [4] 2147943517 = The request could not be performed because of an I/O device error.

Have you been able to fix your DVD drive since your last post?