TMPGEnc problem (average video bitrate)

vbimport

#1

Hi,

i’m trying to convert this video file (info from AVIcodec)…:

“Video : 774 MB, 1050 Kbps, 23.976 fps, 640*336 (16:9), XviD = XVID Mpeg-4, Supported”
" Audio : 89 MB, 121 Kbps, 48000 Hz, 2 channels, 0x55 = MPEG Layer-3, Supported"

…to dvd format but when i get to the last screen before encoding, as seen on this page, even if i lower the average video bitrate to 2000 (the lowest it lets me go), my file size is 134.14%.
my AVI file isn’t unusually big, i dont know why it wont fit under 4.7 gig size

what can i do :confused:


#2

Just an idea but dont worry about the size for now and “BURN” the files to your harddisk then use DVD Shrink to reduce the size of the DVD files burnt to disk and then burn it to DVD Media using DVD Shrink or your favourite software

heres a great guide: http://www.doom9.org/index.html?/mpg/dvdshrink31-main.htm

and a link to download it from also its free!!


#3

VBR audio is almost always a problem for TMPGEnc. Try this first: Open the AVI in VirtualDub (I usually use VirtualDubMPEG2 or VirtualDubAC3).

File -> Open Video File
Audio -> Full Processing Mode
File -> Save WAV

It’ll take perhaps 10 minutes and yield a file about a Gig or so. Use your extracted WAV as the audio input in TMPGEnc. You should be aware that, although TMPGEnc’s inbuilt audio encoder has improved, it never was very good. So an alternate method would be to encode only the video in TMPGEnc, setting it to output an m2v elementary stream. Then encode your audio to ac3 or mp2 with ffmpegGUI. Finally, mux them together with TMPGEnc: File -> MPEG Tools -> Basic Multiplex.

You should do one of these options every time. And this is regardless of the fact that it may NOT solve this particular problem. Yes, lots of ways for DL’ed AVIs to be buggered. Good luck. :wink:


#4

Hi Vincentvdn,

I think the problem is a simple one, please check the last dialog again in your software(Tmpgenc), I think waht you’ll see in the left drop-down box is CD-R Size 700 mb which would give the result as you have mentioned. Try dropping down the left hand side box and selecting DVD-R(UDF) as shown in the link you gave above. You shouldn’t see 100+%.

Hope this helps.


#5

In my experience, often TMPGEnc says that final dimensions are too big to fit on a DVD, but after conversion I obtain a file considerably smaller than a DVD.

If, after conversion, file sizes should be higher than a single layer DVD, than I agree with nerrad: you can use DVD shrink to fit all files on a single disc.


#6

fritzi93’s solution worked fine for me, thanks everyone!


#7

Thanks for replying. Without feedback no one’s the wiser as to what worked. :stuck_out_tongue: