TMPGEnc - No audio. Extra long black screen after movie

I tried converting an .AVI to .MPG for VCD use in TMPGEnc. I went to sleep, leaving it do it’s thing.

This morning, I came downstairs to find that it was as if someone pressed the ‘Stop’ button on 73%.

I checked the processed movie (.mpg), but no audio could be heard:sad:. Video was fine, except for the end of the movie.

After the movie was finished (without audio:(), there was just black playing. Just black.

Is the settings wrong or something?


At the moment, I am using VirtualDub to:

  • File > Save as WAV : To extract the audio to a .WAV file
  • Audio > No Audio;
  • File > Save as AVI : To save the movie without audio.

I am then planning to use (in TMPGEnc) both of those outputted files as the ‘Video’ and ‘Audio’ sources. Should I do this?


Also, when I started up VirtualDubMod, it says that it has detected more than one DivX3 codecs, and one was an ‘illegal hack’ or something. Recently I installed the ‘Nimo Codec Pack’ and the ‘Tsunami Mini-Pack’. What should I do? Is there a codec pack that has lots of used codecs (audio and video - NO spy/adware), which won’t cause errors?

Open up the file in vDubMod, go to Video menu --> Scan video for errors --> Scan. Does it report any errors?
//Danne

0 frames masked (0 frames bad, 0 frames good but undecodable)

When I tried to save the .AVI without sound, it makes a 2.6GB file! Why? The original file is 700mb, so without sound should be less than that. Am I doing it right?
All I want to do is extract the audio from the movie, and save the AVI again - w/o sound.

Your audio is probably AC3 or some other kind of format that TMPGEnc can not handle. If you save it as .wav file from VirtualDub, it will give the audio file a .wav extension even though it may be AC3 or something else. So you need to determine what type of format the audio is first. Use GSpot or file information from within Virtual Dub.

As far as creating a 2.6 gig file… how are you saving the file?
Direct Stream copy on video and No Audio selected on audio settings?

In the past I have had trouble with Xvid encoded movies not converting well in TMPGEnc. My crappy workaround is to encode the video to huffuv (nearly lossless). Then encode the huffuv video to MPEG1 with TMPGEnc. Realize the huffuv file will be around 40 gigs … Frameserving from VD may work too, never tried that

Do the sound manually.
Open file in vDub --> Streams --> Stream List --> Select audio stream --> Demux --> Disable --> Ok --> F7 (Button) --> Video mode: Direct Stream Copy --> Save
Use WinAMP along with it’s diskwriter plugin to decompress your audio stream. Run ssrc (if needed) and toolame on the stream if needed.

Here’s a full guide how I convert avi files to dvd compliant streams.
http://club.cdfreaks.com/showthread.php?s=&threadid=87165
//Danne

Found my problem - Screenshot from GSpot:

But then shouldn’t that mean I can’t listen to MP3s? I can though…:confused:

You have more than likely a directshow filter installed that handles mp3 streams for you. Your problem with TMPGEnc is probably because the audio stream is VBR. Demux and encode it manually as I mentioned above.
//Danne

Originally posted by DiiZzY
Use WinAMP along with it’s diskwriter plugin to decompress your audio stream. Run ssrc (if needed) and toolame on the stream if needed.

^^ I Don’t get this bit ^^

From the link I posted earlier…

  • Open WinAMP --> Ctrl + P --> Plugins - Output - Nullsoft Disk Writer --> Configure --> Check “Convert to format” and select “PCM 44100Hz or 4800Hz. 16 Bit, Stereo” (Set the same sampling rate as vdubmod reported) --> Close all windows --> Add file into playlist and play it --> Change output plugin to DirectSound when WinAMP has stopped.
  • Open up a command prompt, go to the directory where ssrc is stored and type the following syntax (without quotes and remember to change paths):
    “ssrc --rate 48000 --two-pass --normalize d:\path o\my\unresampled\pcm\file.wav d:\path o\my\unresampled\pcm\file_resampled.wav”
  • Once ssrc done go to toolame’s directory and type:
    “toolame -s 48 d:\path o\my\unresampled\pcm\file_resampled.wav d:\path o\my\unresampled\pcm\file_resampled.mp2” --> close cmd window when toolame has completed its task.

//Danne

Yep! It’s all cool! It works now!:bigsmile: :smiley: Thanks guys. It took 3 days, but I got there.

Thanks:bigsmile: :bow: