They DON'T recognise my BenQ DW1620

vbimport

#1

I got a BenQ DW1620 OEM (with f/w G7H9) dvd writer installed as master in WinXP Pro with SP1, both nero drive info and dvdinfopro detect it okay. BenQ booktype management 8.3/8.4 and Qscan 1.0 do not recognise it, this drive dose not show up in the pulldown menu (i have a dvd-rom drive as slave). Then I flashed the f/w from G7H9 to B7T9 using “WinDWFlash.exe” and “b7T9.cvt” downloaded from the Unofficial BenQ firmware page as stated in the FAQ “http://club.cdfreaks.com/showthread.php?t=121105#fw” (FYI the method in “http://club.cdfreaks.com/showpost.php?p=720280&postcount=15” dose not work for me, i don’t know why). The flash was sucess drive info shows BenQ DW1620 B7T9 but still BM8.3/8.4 and Qscan1.0 fail to recognise the drive.

Anyone knows what is the problem and how to solve it?

Thank you very much!!

SLo


#2

Hi - if you have a motherboard using a NFORCE, VIA, or SIS chipset [especially the first two] strongly advice replacing [rolling-back] any third-party IDE drivers with the default MS ones in XP.


#3

My M/B is Asus P4P800 Deluxe according to the User’s Manual the north bridge chipset is Intel 82865PE and the one for south bridge is Intel ICH5R w/ RAID0 support. Does it matter?

Thank you!!

SLo


#4

Look for and kill “Intel Application Accelerator”
Oh, and if you still have trouble, flash that drive again from Windows Safe Mode (be furiously tapping F8 key during startup, use arrow keys and then enter to select safe mode) use the firmware located at www.benq.com .


#5

There is no “Intel Application Accelerator” installed in my PC.

I tried to re-flash the f/w with B7T9.exe (http://support.benq.com/files/storage/Firmware/DVDRW/DW1620/B7T9.zip)
in both safe and normal mode but failed. The BenQ DW1620 drive did not show up in the “Device:” of the “DW Flash Tool (Ver A-6.0)” window so i could not carry on the flash.

Any suggestion, thank you!!

SLo


#6

When this happened to me, it turned out to be an ASPI issue.

I solved it by finding and downloading a package called ForceASPI. It will contain a sub-package called KillASPI. Run KillASPI to eliminate the ASPI drivers, and then see if your utilities work.

You can then decide if you want to use the other part of the ForceASPI package to reinstall the default ASPI layer. I found I didn’t need it, since I use Nero and it uses its own ASPI layer.


#7

You can find here:
http://radified.com/ASPI/forceaspi.htm