The drive you save could be your own

vbimport

#1

Hi there, cheers for readin.

Got a sony dvd-rw dw d22a.

Worked pretty good before i flashed it:

Never flashed a drive before, so got educated first (or so i thought).

Downloaded LtnFw to flash the drive to the liteOn sohw-1633s. Got the firmware (1633s.bs41.stock), backed up my original firmware (twice, did the checksum check), then ran the 1633 installer. The flash reported successful. Rebooted, checked in bios then in xp: everything was good. I then ran the LtnRPC prog to disable the region settings on the drive: again read up on this alot, and it worked fine (got the output from LtnRPC that i expected). I then put a dvd (pre-pressed) in the drive and discovered it was being read really slow: tried it with a data cd and explorer crashed trying to read it. My DMA settnigs were fine (control panel-device manager-etc) - udma66 enabled.

I then flashed back to my backup firmware: drive was now recognised as the sony dwd22a, but the same read performance remained. Checked DMA- enabled no problem.

Can anyone shed some lite on this please? My guess is that the eeprom may have been corrupted in some fasion that has changed the dvd-calibration data? LtnRPC could have done this (not Ltnfw as i understand). But the drive is not ‘dead’ - just performance is terrible. Tried the drive in another machine with the same problems (to check my cables, make sure that my system wasnt just reporting udma incorrectly). Also, should I have used ltnfw to flash back to the sony (BYS1), or was this a mistake? Any replies much preciated.

btm


#2

Yo-

Do a “Search” for your answers - to get the fullest field of answers for your question-

Mike


#3

Thanks for the reply mate, I have done some searches for help on my problem but cant seem to find anything to help me (Ive been browsing for three days now - please dont think ive just registered at cdffreaks and posted a question expecting everyone to just solve my prob). Ive read alot of stuff, but ive tried all the things i can thnk of:

tried flashing to bys1 (found a link on a post here at cdfreaks)

tried bys2, bys3 (binaries and executables)

tried crossflashing with same firmwares

used ltnfw (flashing in dos, following instructions exactly, my bup firmware, bys1, bys2, bys3)

tried the drive on an ide channel on its own (changed jumper to pri and sec and plugged in accordingly)

And more (cant remember all the stuff ive tried!). The only thing i can think of is that there is a problem with the aspi layer, but i know little about this. Ive been reading up on this, tried installing it (downloaded from adaptecs site) but keep getting a corrupted install (ive got nero6 which i use to get info on the system-aspi layer installation etc). I tried all this before i posted here, but now im stuck. Any more pointers or advice would be greatly appreciated.

btm


#4

read some more posts and tried a few more things:

uninstalled powerdvd and nero

uninstalled ide drivers (on reboot windows reinstalled as expected)

unplugged other devices (incase of a power issue)

installed aspi layer (using forceaspi7 - aspichk reports functioning install)

still no joy :sad:

any thoughts or suggestions appreciated

btm


#5

Have you tried running the BS0S firmware from the CodeGuys?
http://codeguys.rpc1.org/firmwares.html

Believe the BS4x don’t play nice with all the 1633S drives…


#6

I can give you eeprom backup from original BYS3


#7

OK well i had a liteon drive and it gave me problems too when i had another dvd burner drive in the system. It doesnt seem to respond well with other drives, so i just took out my liteon drive, and have been using the nec nd-2500a for the longest time now hacked with less problems and headaches.

i suggest you ebay that drive and just get the new cheaper nec drive (3210a model or something like that) from newegg for under 60 dollars with free shipping. its possable that its something with hardware conflicts with liteon dvd burners. im not sure but i dont trust them anymore. i give top honors to nec and pioneer. they seem to be the leaders now in the optical drive industry.

Hope that helps, if you want to salvage the drive, update the firmware in dos, with a floppy disk the old fasion way. im sure your smart enough to figure that out. if not get a smarter friend to do it for you. you can also try this out, taking out other components in your pc that might have conflicts with that drive. maybe the drive is using the same irq with some other drive or pci card in your system. so check that, and or try different media. its also possable that you have just a bad drive. so if you can rma it now then do it asap. Lastly make sure that inside device Manager that the drive is set to dma. if its not running as dma then your pc is gonna use up alot of cpu power to burn movies or data. you can test it buy opening up taskmanager with ctrl+alt+delete.

Good luck burning!! Trizzy Masta