The big LITE-ON SOSW-852S / Sony DW-D56A thread

Hi i replaced myfaulty dvd-rw in my laptop (Targa XP1 athlon 2500 1gb ram 1 yeasr old win xp pro sp2) with a new one a friend got me when he was in the US it is a LITE-ONsosw-852s it works fine 4x plus and minus, however I was browsing the net and the reviews of this drive said that it was an 8x and also was dual layer.neroinfo and dvdinfo both reported it as 4 speed plus and minus only with the box for dual layer blank. My laptop is reasonably new with the latest BIOS . the specs are on this site http://www.ab.pl/eng/prasa/aktualnosci.php?id=2374
anyone got any ideas

You may need to update Nero InfoTool and DVDInfoPro… What is your drive’s firmware version?

Update
Find the firmwares in post #45 of this thread.

The hardware is capable of burning 8x ±R and 2.4x DL but the firmware for this drive may limit these capabilities. I’d also be interested to hear what version it has.

I am using nero 6.3.1.25
acording to nero infotool the firmware is PSR7
I am also using dvdinfopro v3.21. I would do a fresh install of windows but I don’t think that it would make any difference. I was talking to my friend who brought it over from the states and he said thet they were being used in acer aspire machines

I have removed this dvd from the laptop to double check
it says model sosw-852s august 2004 f/w prs7 h/w:01
there are no jumpers to change
I have searched for info for this on liteons site but its not listed
the nearest I can find are SOHW-832S or SOHW-812S but these are full size drives

The drive might write +R DL discs even though the box is unchecked… Ask for a firmware update from Acer.

I have also a LITE-ON SOSW-852S in my Acer TravelMate 4001WLMi and DVDInfoPro 3.23 provides me the following information (see attached file)


Your DVDInfoPro screenshot shows the first LiteOn dvd burner firmware capable of reading DVD-Ram I have seen.

But it doesn’t support DVD+R DL :confused:

I have uploaded my firmware and eeprom for those who are interested…

http://www.ezshare.de/files/18253/SOSW-852S.rar.html
(just click on the link and then on Download: SOSW-852S.rar)

This firmware looks quite strange. The +R media table is in bank A, all other burner firmwares use bank C. Also the firmware has some cleartext debug messages. The calibration data in the eeprom is not compatible to the addresses used in all other firmwares.

Can I patch it somehow to enable double-layer support?

Has anyone actually tried buring a DVD+R DL disc with this drive, or are you all just complaining about there not being a check in the checkbox?

There is no +R DL support in the PRS7-3 firmware.

Has anybody another version of the firmware, which supports +R DL?

should I risk the new bios?

No.

PS01 - 2004/06/28 15:09
PRS7 - 2004/07/14 16:15

When flashing the 852 firmware to a x11 drive the firmware thinks the tray is open when it is closed, which worked fine before with all other firmwares I tried, including 851/812/832 firmwares. This slimline drive firmware uses an inverted tray open signal, so the available firmwares from other drives will not work here.
Also this firmware does not work with a S030 bootcode (nothing realy wrong with that), the drive was dead after my first try. Dos mtkflash 1.80 from dhc014.rpc1.org did not accept the x11 binary files to restore the drive, 1.83 accepted them and brought the x11 drive back to life, as expected.

Seems like that PS01 firmware does have +R DL support, which is consistent with the drive’s specifications. The PRS7 is not a standard LiteOn firmware–it’s some sort of OEM version, and it is not uncommon for there to be variations in certain OEM versions depending on what the OEM customer wanted…