The Asus DVD E616 Mystery

ASUS has a new firmware for the drive v2.1. And it is in a windows exe (good if don 't have a floppy like me).

But as many of you have noticed the drive shows sometimes Z.0 and not 2.0 as its firmware. The updater will refuse to continue.

Well i was lucky and i understood that the drive sais Z.0 if it is master on the secondary controller and 2.0 if it is slave (well i have both asus and yamaha in cable select in ata 100 round cable).

But even when i get the firmware to be 2.0 and the updater continued an error appeared.

It sais the flash completed and and error: verify NG and the firmware is still 2.0 or Z.0.

Does anybody knows what that means?

Thanks a lot for the firmware update info, I hadn’t been checking since my E616 doesn’t work well anyway. I’ll try it when I get home today, if it works I’ll back it up to .bin and post it for download, that way you can use mtkflash/mtkwinflash to do it.

You got further than I did :frowning: . I can’t even flash it under Windows XP (all compatibility modes) or 98SE. If anyone has actually managed to flash this firmware, I strongly urge you to back it up and send it to me - Removed

Back it up using

mtkflash x r /b /m filename.bin

Here’s what happens to me:

The drive is, like yours, master on the secondary channel. I reflashed it with the 2.0 bin firmware just to make sure nothing had gone wrong before, still nothing. Yet another reason (after my P4S8X) not to buy Asus ever again.

This happened to me too but if you put the drive in the slave it will find it and continue. It can 't find the device because it looks for 2.0 and shows Z.0. You have to change the cables to get after this.

Ah. You mentioned that the revision changed based on master/slave but I would think their own firmware flasher would take that into account. I’ll try again today.

my Asus DVD E616 is connected as secondary slave still the flash program cant find my drive.

Surely someone has been able to flash this…I posted at Asusboards.com about this, and sent a complaint to Asus.

Okay, I managed to flash by switching it to slave. I have backed up the firmware and it’s now available for download in bin format. As with before, firmware revision is 2.1 as a slave and Z.1 as a master.

I highly reccomend either MtkWinFlash or MTKFlash 1.62. Unlike earlier MTKflash versions, this version does not take extremely long (>10 minutes) to read or write. Both of these methods are, however, untested by myself so please post back about your experience flashing it and any differences you notice. Remember to unRAR with WinRAR 3.11 or greater.

Asus E616 Firmware 2.1

Ok thank you very much BadReligionPR.

I flashed with no problems :bow: :bow: :bow: .

I really don 't get it with this Asus dvd… Not even the official flasher don 't work properly.

Yeah, we’ll put it up. Thanks a lot BRPR

Thanks a lot.

Here it is BRPR, thanks.

http://forum.rpc1.org/dl_firmware.php?download_id=24

I find how to flash E616 to v2.1 in XP !!!
Just use the function of XP …
When you select the program to excute as if it works under Win98/WinME, you will get a E616 with v2.1 without any error !!!

http://hyperphoto.photoloft.com/view/Image.asp?s=cano&u=1759428&a=1339648&i=10470455

Hi everyone here!

I’ve used search engines to look for “DVD Region Free” for a long time and finally got here.
This is a very nice and useful place.

I bought a new “Asus DVD Rom E616” a week ago because I was told that it’s Region-free.

I’ve downloaded the "Asus E616 Firmware 2.1 " here and extracted it to a temp file on my computer.
I got a file named “ASUSE616.bin”.

When I tried to run it, I got a popup window offering me some program choices to choose.
I don’t know which one I should use and don’t know how to flash E616 to v2.1
so that I can make my DVD region free.

I’ve also downloaded “MtkWinFlash” and “MtkFlash162”.

Because they are risky tools and I have no experiences on how to use them,
could someone be kind enough to tell me how to flash?

I’ve used the “Nero INfoTool” to check my DVD Rom
and get the info as below:

Drive: Asus Dvd-Rom E616
Type: DVD-ROM Drive
Firmware Version: Z.0
Buffer size: 512 KNB

Region Protection Control: RPC II
Region : None
Changes User: 5
Changes Vendor: 4

My computer system info:

MB: MSI VT8601T
CPU: Celelon 1.3G
Ram: 256M
HDD: 20G
FDD: 1.44M
DVD: Asus Dvd-Rom E616
CD: Asus CD-S400/A
OS: Windows Me


Thank you in advance!

TOM

There is a basic MTKWinFlash tutorial on it’s page here http://digi.rpc1.org/mwf.htm . Basically just open up the ATAPI mode and select the Asus DVD, then select the bin file and click flash. Alternately, if you no which place on the IDE channel/cable the Asus is located, you can use direct IDE port flash mode
1=Primary master
2=primary slave
3=secondary master
4=secondary slave

Hi BadReligionPR,

I flashed it according to the instuctions at the page:
http://digi.rpc1.org/mwf.htm

This is the first time I flash my DVD drive.

My Asus Dvd-Rom E616 is conected to IDE 2 as a Master.
I used “MtkWinFlash” and lauched its IDE MODE Version.
I set it as below:
Target Drive IDE PORT: 3

I clicked the “Browse” button to load the bin file:
Source F: emp\ASUSE616.BIN

Then I clicked “Flash Drive” button.
Now poped up a confirmation box. I clicked “OK”
And I saw the flashing process.
When it finished, I restarted my computer.

I used the “Nero INfoTool” to check my DVD Rom
and get the info as below:


Drive: Asus Dvd-Rom E616
Type: DVD-ROM Drive
Firmware Version: Z.0
Buffer size: 512 KNB

Region Protection Control: RPC II
Region : 5 <==( This was “NONE” before I flashed it, I don’t know why it’s now set to 5 )
Changes User: 4 <==( This was 5 before I flashed it )
Changes Vendor: 4

My DVD is still in RPC II and
the flash set my DVD-Rom to region 5 (before flash, it’s none).
I have only 4 changes left.

I don’t know why.
Is this ASUSE616.BIN for making ASUS DVD-ROM E616 Region free?

Could you tell me how to do it?

Tom

It doesn’t seem that the firmware flashed right, or else it would display Z.1 as firmware revision. This bin file is unmodified 2.1 firmware, not patched. There is a simple button trick to make the drive region free somewhere.

Perhaps you should try normal MTKFlash? It requires a DOS boot disk, with mtkflash and the bin on the floppy too. Then type

mtkflash 3 w /b asuse616.bin

I asked Hidi for help. Hidi is so kind that he told me to replace the asuse616.bin with the right bin file “e616_20p.bin” and flash it again.

I flashed my dvd-rom with MTKwinFlash again according to Hidi’s advice and it’s done.

Perfect! Now it’s REGION-FREE!!!

I’m very happy now!

Many thanks to Hidi and BRPR!!!

Have any of you tried the new 2.2 firmware?

ftp://ftp.asus.com.tw/pub/ASUS/dvdrom/e616/DVDROME616_22.exe

I wonder if they fixed the problem… If any of you could send a binary backup I’d appreciate it. :wink:

Damn, I’ll have to rearrange the master slave settings again…maybe today, if not, tommorow if someone else doesn’t beat me to it.