The 40x writer firmware fucked up

vbimport

#1

I've tried to patch the 40x and it went terribly wrong:

atapi command error or something like that

I tried to reboot and IT's gone, can't be detected anymore in the bios.

I can't find the firmware on liteon's site 'cause it's under construction, but I ask u guys now: IS THERE A POSSIBILITY 2 GET IT BACK AS IT WAS BEFORE? without sending it back to the shop?


#2

http://club.cdfreaks.com/showthread.php?s=&threadid=42502


#3

And:

http://forum.cdfreaks.com/showthread.php?s=&threadid=45977


#4

I know, but that aint a solution, only warnings, prob is: I’ve already done it, now I’m just seeking a way to restore my old firmware.

thx anyway


#5

And what is the difference between “installing newer firmware” and “installing older firmware” if you use mtkflash?


#6

none I think, but the problem is that :

  1. I can’t get my drive detected in my bios
  2. I can’t download the original firmware 'cause it is (temporarily) unavailable at http://www.liteon.com

#7

Perhaps you can boot into DOS, use the MTKFLASH thread to recover your drive.

OC-Freak has quite a good collection of firmware (check the sticky posts) that you can download.

Hope this helps.

With reference to your first problem, please check that the drive/ide channel is not set to “Not Installed” or something similar in your BIOS.


#8

If you killed your firmware, its normal that your BIOS doesn’t find the drive any longer. This is no problem, mtkflash doesn’t care what the BIOS tells.
I gave you the link where to download firmware files.

OC-Freak posted a link to the thread that explains the usage of mtkflash. Please read it.


#9

THX 2 everyone, especially 2 OC-Freak, 2 help me out, it works fine again