Terribly slow burns w/ BenQ1620

vbimport

#1

Hi guys. I recently reformatted my Dell PC, and after doing so, my trusty BenQ1620 takes forever to burn a disc nowadays. Instead of ~7 mins @ 8X for a full disc, it takes 3-4x longer than that. What could the cause be? I’ve checked, and my drive is in UDMA2.

Cheers and thanks a million,

MJ.


#2

Are chipset drivers installed? What’s drives DMA mode in devicemanager.
Visit Dell homepage for manufacturer specific drivers.


#3

Thanks for the reply, pinto! I installed chipset drivers and verified that my drive is in Ultra DMA Mode 2 in Device Manager. But I tried to burn a disc, a 1 GB MKV, and it took 10 mins; so, sadly, the problem persists.

Jie.


#4

Update: It turns out my drive was in PIO mode – my other drive was in UDMA2. I tried uninstalling the burner in DM then re-booting and manually setting it to “DMA, if available.” However, that didn’t fix the problem.

Do you have any more advice, pinto?


#5
  1. try new cable or
  2. swap burner Master/Slave config around

#6

I just solved the problem! Using Device Manager, I uninstalled both DVDRWs in addition to uninstalling both IDE channels. Following a reboot and a few minutes to recognize the hardware anew, the DVDRW was good to go!

Thanks pinto and mac for your help!!!