Terrible output quality with interlaced source when converting to generic

vbimport

#1

When converting a DVD to generic (or mobile) I cannot find any option to deinterlace the source. From time to time there are few DVDs still containing interlaced contents. For instance most of the additional materials on SickO are interlaced (at least in my region R2).

Is there any option to deinterlace it while converting it? As it is now the output contains horrendous artifacts on the edges. FOr instance the xvid encoder has an option to choose the type of deninterlacing (odd, even or interpolate). WOuld it be possible to get access to thisd option in DVDFab too?

Thanks.


#2

Same issue with some of my DVDs. :frowning:


#3

There is no option in DVDFab for de-interlacing. It has been requested a few times in the features request thread. What I have found that works for me is to use the DFDFab convert the main movie to VOB then use AVI.Net from http://www.clonead.co.uk/ to convert it to AVI. It has the de-interlace option. :slight_smile:


#4

[QUOTE=DaGeekster;2013484]There is no option in DVDFab for de-interlacing. It has been requested a few times in the features request thread. What I have found that works for me is to use the DFDFab convert the main movie to VOB then use AVI.Net from http://www.clonead.co.uk/ to convert it to AVI. It has the de-interlace option. :)[/QUOTE]

Thanks for the pointer. I will try that, but kind of silly when I have already paid for DVDFab to do the job :frowning:


#5

hi,

We will add deinterlacing option and them you can conrol it by yourself.

Thanks.


#6

[QUOTE=Ting;2014051]hi,

We will add deinterlacing option and them you can conrol it by yourself.

Thanks.[/QUOTE]

Yahoo! Thank you Ting, That will help a bunch!

Larry


#7

You could always have a play around with these parameters in the profile you are using.

I noticed this in the new profile documentation.

<deinterlace mode=“0” method=“0”/>
<!-- deinterlace mode - specify video deinterlace mode, support value = “0” - auto decide deinterlace or not, “1” - force deinterlace
–>


#8

I just tried in auto detect mode (=0) and it does not seem to work as expected: video is still interlaced. I will do more tests… :frowning:


#9

[QUOTE=alex60;2014030]Thanks for the pointer. I will try that, but kind of silly when I have already paid for DVDFab to do the job :-([/QUOTE]

Well I agree that is is kind of silly but AVI.net is free and seems to do the job quite well for de-interlacing the movie. But I am glad that Ting is working on adding that capability to DVDFab, that makes it an even better all-in-one program IHMO :bigsmile:


#10

Hi Ting,

Any update? This issue is not fixed in version 4.1.2.0 yet.

Thx in advance.:bow:


#11

Hi,

Another DVDFab user, any news on this feature?
Using my DVD recorder to transfer a load of old tapes to DVD, then putting them on my PC.

It seems the tape player is interlacing like there is no tomorrow!


#12

Bumping the message up again. THis is still not fixed :frowning:

Come on Fengtao any other similar tool out there has a “de-interlace” option.

Lots of other less importnat features are implemented all the time. Why not this one? Or maybe is there and I haven’t figured out how to enable it?

Thanks.


#13

[QUOTE=alex60;2172263]Bumping the message up again. THis is still not fixed :frowning:

Come on Fengtao any other similar tool out there has a “de-interlace” option.

Lots of other less importnat features are implemented all the time. Why not this one? Or maybe is there and I haven’t figured out how to enable it?

Thanks.[/QUOTE]

And now my apologies. IT IS FIXED! I still would like an option in the settings screen, but the workaronud of manually editing a profile it is now working in fact.

Just add the deinterlace tag to the <video> section of whatever profile you normally use (I just used notepad to do that) and save it giving it another name in order to distinguish it from the original profile you modified.

<video>
[B]<deinterlace mode=“1” method=“1”/>[/B]
<size list="" />
<subtitle mode=“0” />
<encode codec=“xvid” fourcc=“XVID” bitrate_kbps=“900” >
<mode value=“real_time” list=“real_time, high_quality” />
<thread set=“1” value=“1” />
</encode>
</video>

Remember also to change the tag <profile name> at the beginning of the profile otherwise both will be shown with the same name within DVDFab making it impossible to see which one is deinterlaced and which is not.

Thanks


#14

Has this optioned been implemented yet? i have a couple of my dvds when converted look terrible due to this.


#15

It is not in the UI but you can apparently manually put it into a profile. See post #13 from alex60. I have not tried this myself because I don’t have the playback problem.


#16

they edited the post where it changes,


#17

If it can help here is how my non-interlaced profile looks alike:

[B]<profile name="generic_deint.avi.xvid.mp3" version="200" device="generic" tag="dvdfab" description="The profile is used to create avi(xvid + mp3) file, which can be played on PC or supported device." >
<common>
<file format="avi" onefile_size_mb="700" number="1" />
<audio copy="0" codec="mp3" channel="2" >
<freq value="48000" list="32000,44100,48000" />
<bitrate value="64000" list="64000,96000,128000,192000,256000,320000" />
<volume percent="100" />
</audio>
<video>
<deinterlace mode="1" method="1"/>
<size list="" />
<subtitle mode="0" />
<encode codec="xvid" fourcc="XVID" bitrate_kbps="900" >
<mode value="real_time" list="real_time, high_quality" />
<thread set="1" value="1" />
</encode>
</video>
</common>
<acodec name="lame">
<common ver="0" layer="2" />
<attr ch_mode="0" quality="0" private="0" orignial="0" checksum="0" copyright="0" />
<vbr method="-1" max_bitrate="224000" quality="0" abr="8" />
</acodec>
<vcodec name="xvid">
<motion motion_search="5" vhq="0" qpel="0" gmc="0" chroma_me="0" />
</vcodec>
</profile>[/B]