System lag possible DMA related pls aid me

I consider myself to be technically inclined but this issue has been bothering me for a while.

My system is a Pentium4 3Ghz 1.25GB ram Pioneer 110DVD+RW MCE2005

System symptoms are generic and seems related to DMA access

Only my drives attached to my PATA is slow on access or writing but the ones on SATA run absolutely fine. On primary IDE channels there both set to UDMA6 where as my secondary on Not applicable even though its suggested for DMA if available. Ive tried uninstalling the drive and the secondary ide channels. didnt work. Tried running regedit and manually adding DMA there which did squat. I did have a DVD that wouldnt read but after a few tries the system picked it up so my guess is that winxp struggled withthe disc and reverted to Pio mode but the question is how do I reverse the damage? I do not have System restore point available.

Welcome to cdfreaks. :slight_smile:

What’s the make of your mobo and what chipset do you have.

The burner has to be run in UDMA4 mode.

Pinto2 - Dell custom board using 915 Chipset

Chef - I would If I could even get the dang burner to recognize DMA mode at all.

Just so were clear nothing I do can keep a DMA setting for my PATA drives as soon as I use some sort of software to force DMA2 or any DMA setting at all a restart reverts it back to Not applicable. I took advice on removing key registrys to see if that could change it well It used to say PIO now it says Not applicable.

Check the BIOS settings first. DMA (IDE) should be set to AUTO.

on the Dell 915 There is no custom settings for the IDE channel for pATA only for sATA. Whats even wierder is the system cannot identify either pATA drives in the BIOS yet as soon as you hit windows the drives are there just not UDMA mode. I should note that at one point the system did work correctly with these settings before but 3 windows formats later this turns up.

Update: I attached a picture of what my device manager tells me on the left side for secondary IDE channel. This persists even if i uninstall drives and ide controller. On the right side is a utility i tried using when suggested by another forum guru. The utility wants to force DMA but I claims I dont have a secondary channel and my primary channels dont have DMA support either.


I recommend you to visit Dell and download propper chipset drivers if you are not able to set DMA wit M$ default ones. :slight_smile:

Third party “tools” won’t help you out.

No I AM using dell’s drivers. Ive used the 3rd party tools out of desperation so any more suggestions would be helpful. Just to refresh your memories this only happened after windows failed to detect a dvd I tried to to play and after several tries windows oddly detected it. I associated this to the problem windows has when it takes unreadable discs and reverts back to pio settings to fix the problem.

Then just uninstall the IDE channel drive is connected to and restart.

If you get a choice to choose drivers after restart choose Intel ones, or run your chipset installer once again. :wink:

Edit.
BTW, to my knowledge there is only one IDE channel on Intel-915 mobos (regarding your pic above). But then I might be wrong… :smiley:

That seems to be so - DELLs are different.

Different in what way…?

AFAIK Dell uses cheap OEM mobos that only follow basic Intel 915/ICH6 design standard. ICH6 has embedded SATA support and some kind’a RAID (don’t recall it’s name). Maybe it’s that topic poster sees in his device manager.

But all this can easily be checked if we get exact model/type of compu, and with Nero InfoTool.

In case of IDE controllers (#) and how they are used.

Im sorry I dont know why I said it was called the 915 because its an 775 socket CPU its actually the 945.

pinto2 - As ive mentioned in the first post ive tried uninstalling the device drivers for the IDE channels which automatiically installs itself over. Dell does not have a custom chipset driver package instead it just links you to the ones on intels hosted on dells website.

chef - please elaborate on your question regarding how IDE controllers are being used?

More confusing shots:Whats odd is windows says I have no ASPI installed could this have a relative issue? On the left you see a Nero info shot of my system and both my pATA drives with DMA off and both my sATA drives on. On the right you see a shot of device managaer which can detect the drives thats about it.


Both have DMA off, that’s weird…

You must on all Dells go into the BIOS and turn all channels on and set them to Auto or whatever is appropriate! Hit F2 on boot!
Most Dells are shipped with the secondary IDE turned off and maybe the slave on primary!
Also reflash your Bios at Dell if there is a current one!
All Dells are shipped as CS on IDE channels/change them to master and slave.

Is this a new system?

What is your exact computer model and number? 8400,9100,9150, XPS, ???

http://support.dell.com/support/index.aspx?c=us&cs=04&l=en&s=bsd&~ck=mn

Also I have had 7 Dells dude at home over the last 4 years and thousands at work! All great machines at a great price! :cool:
All 7 are still working in various houses! :cool:

PS/ Dell Intel and AMD mobos are standard custom featured by Intel or AMD.
They have all the same funtionality and design of any other MOBO built by INTEL! Dell leaves off connections that their millions of customers will rarely use if ever! For example most new boxes have one IDE channel. If you have two, you must have a higher end box from Dell! They also disable functions that are not in your original configuration from the factory!

On the back of the drive!

Man! How many HDs do you have? Looks like you have two on the secondary and a SATA drive?
With that much hardware you may risk running out of system resources(old IRQ stuff). I installed a USB PCI combo firewire card(8 resources) and it hosed my Dell! Some devices use multiple resources!
My advice is put on the box just your necessities and then add the other hardware one at a time.

Yeah, we all have been waiting for this info since post #1.

BTW, checked Dell mobos with Intel945 chipset and ICH7, all only have one IDE channel AFAICS.
Example OptiPlex .

Dimension E510 A.K.A. D5150 A.K.A. E051

Will try the cable select thing and see if that resolves the detection issue but I have more of a quarrel with the DMA thing.

I have 1 80GB on sATA 160GB on sATA the Pioneer DVD+RW on pATA and a 200GB on pATA as ive stated many times the pATAs are running extremely slow to point where accessing either one causes horrendus lag as opposed to just slow transfer speeds. Access meaning burning, copying, cutting, pasting anything that requires disk access on pATA will bring the system to an unusable crawl.

The only option I have in the BIOS for my pATA drives is whether I can turn them on or off althoguh I have set them both to ON status the BIOS tells me the drives are UNKNOWN and during boot will say Device 3 and 4 (pATA) is not plugged in which is obviously wrong if windows can see them.