SVCD burning issue on SONY DVD DW-D26A

vbimport

#1

Ok, here’s the problem I am having.

A year ago, I got a new DVD/CD Burner combo, a Sony OEM DVD DW-D26A. I also own a Panasonic S35 DVD player. With my old CD burner I burned a lot of VCDs and SVCDs and they played fine on my DVD player (I got a couple of coasters here and there, but otherwise it was ok).

Now, however, none of the SVCDs I’ve been trying to burn will work on my DVD player. They work fine on my PC and on my in-law’s DVD player (some JVC model) but not on mine. On my player the video skips, jumps and is full of artifacts in every frame and the audio is full of chirps, hisses and beeps, some of them threaten to blow my stereo speakers.

I’m running a Linux 2.4 kernel with scsi emulation (kernel module ide-scsi) and using vcdimager and cdrdao 1.2.0 to burn the SVCDs.

When I try to burn, it loads the “generic-mmc” driver and cdrdao reports:

“ERROR: Drive does not accept any cue sheet variant - please report. ERROR: Writing failed”

This problem goes away when I force the use of the “generic-mmc-raw” driver by “–driver generic-mmc-raw”, however I think it is the use of the raw driver that is causing my disks to malfunction on my DVD player. Disks I’ve burned with either my laptop or my old burner (both using the “generic-mmc” driver) work find in my player.

I have tried to find some method or workaround that will allow me to maximize the compatibility of the SVCDs I am producing, but so far nothing I have found has worked.

I have tried burning at 2x, but this makes the disks completely unplayable (nothing but artifacts, skipping video and chirping audio). If I try burning at the max speed (40x for my burner) the situation is much better, the video is almost playable, but there’s still artifacts, skips and chirps about every 30 seconds or so.

This is somewhat odd, because everything I’ve read says to try to burn at a lower speed if you’re having compatibility problems.

On another forum I found something regarding Panasonic S35s not liking SVCDs burned using the .cue/.bin format, so I tried using “bin2iso” to convert to an iso and burn it with “cdrecord”. I managed to burn it without using the raw driver, but the resulting disk does not play in any device (they all say its format is invalid).

I have also tried various media, from no-name CD-Rs to Fujitsu gold photo CD-Rs and it makes no difference.

My burner is currently using the JYS1 firmware, and I have found updates for JYS2 firmware, but I’m reluctant to try flashing the drive without knowing what the JYS2 changelog is…

I believe the problem is caused by two things:

  1. Using the “generic-mmc-raw” driver.
  2. An older DVD player with less error checking.

Has anyone else successfully used a SONY D26A with the “generic-mmc” driver? I don’t believe I should be getting the “cue sheet variant” error.
Does anyone know if upgrading my firmware will fix this?
Has anyone seen this kind of problem before?
Any other suggestions?


#2

I think that most of the advice given here will be Windows orientated but maybe some general suggestions will help.

In a Windows environment we’d suggest ensuring your HD was regularly defragged & that DMA is enabled on your devices. No idea about how you do that under Linux.

DVD burners are not the greatest CD writers & sometimes it’s better to keep a dedicated CD writer in place for CDs.

Media. Some of the best available is Verbatim. Pastels & Super AZO are my favourites.
Also I’ve tended to use rewritables (Verbatim of course) for any SVCDs that I burn.

Burn speed. Most here reckon for quality DVDs that the rated speed is the best starting point rather than dropping the speed down.
For CD-R, again most here suggest 16 or 24x as the max for burning Audio CDs. I mean CD-R with audio , not Audio CD-R media if you follow that.
So it might be best to try this range of speed to see if it helps.

IDE Cables. What IDE cables are you using? It’s best to go for good quality 80wire (aka ATA66/100/133) cables.

Finally , yes any firmware update is worth doing although changes tend to be for DVD media rather than burning CD media.

Don’t know if any of that helps.


#3

I’m running the reiser filesystem, which defrags as it goes, so I’m ok on that front. As for DMA, I’m pretty sure it’s on, I’ll check when I get home.

Under linux you do it like so:

hdparm -I /dev/hdd

(but substitute your drive for /dev/hdd)

You mean the rated speed for the media, not the drive right? I’ll give that a shot, I’ll try with the speed listed on the disk as well as 16x and 24x and see what happens.

I’m almost certain my drive’s hooked up to the onboard IDE controller with a 40wire cable. It shows up as /dev/hdd, which is the second slot of the second IDE channel (IDE1 = hda,hdb IDE2 = hdc,hdd etc…) and I know IDE1 and IDE2 are the onboard standard ATA. I also have two onboard ATA66 channels and two ATA133 channels on a PCI controller. I didn’t think optical drives took advantage of ATA66/100/133?

I’ll try hooking up the drive to an ATA133 or ATA66 channel using an 80wire cable and see what happens.

That will be my last resort. Do you know where I could find a changelog for the JYS1 and JYS2 firmwares?

Thanks!


#4

Some DVD Burners run in Ultra DMA mode 4 (ATA 66). Pioneer & Liteon being 2 brands. Also some DVD-ROMs also do.

Sony don’t make their own burners but rebadged others like Liteon. I think that yours is a rebadged Liteon 1673S, so maybe it needs ata66.


#5

The Panas are very picky players, either for CD-R or DVD-R media, not to mention +R and RW media.


#6

Ok, I verified that my drive is using DMA (udma mode 2) and switched it to the onboard HPT366 ATA-66 IDE controller using an 80wire cable (although, as far as I can tell, you don’t need an 80wire cable until udma mode 3).

Didn’t seem to make any difference.

I tried burning at 24x and 16x and that just made things worse. The media I currently have varies from 48x-52x. I’ve had the best luck so far buring at 40x.

Then I tried flashing the drive to JYS2 firmware.

No change.

And just for good measure, I upgraded from Linux 2.4 to 2.6 to get away from the “SCSI-emulation” of 2.4 and access the drive directly with IDE.

Again, no improvement.

I also tried burning the same disk image from my Win2k partition (after verifying that DMA was on, disk was properly defragged etc…) using Nero 6.* and the results were even worse. I couldn’t even get a semi-playable disk at 40x.

Has anyone seen the “drive does not accept cue sheet variant error” before?

I’m not sure, but it seems like the drive should accept the cue sheet, why wouldn’t it? Is there anything I can do to the .cue file itself to make it acceptable to this drive?

Also, has anyone else had problems burning cue/bin files with a SONY DVD DW D26A (or Liteon 1673s?)?

The drive should work without having to resort to ther raw driver shouldn’t it? Is there some kind of special workaround these drives need?

Any other ideas?

Thanks!


#7

Hi,

as you have a working Windows installation and Nero:
Burn a data disc (or whatever you like) and make a quality scan using Nero CD/DVD speed. Post the results here.
It is not impossible that the drive is faulty and needs to be replaced.

Michael


#8

Tried that.

It said “error initializing test” when I tried to do a quality test, and gave me a BSOD on the HPT366.sys (Highpoint ATA-66 driver) when I tried to run the “scandisk” test…

Maybe I should put it back on the regular ATA-33 controller?


#9

Why would you connect an ODD onto such an controller?
You really shouldn’t, IMO.


#10

Well, TimC recommended I use an 80wire cable… There’s not much point in doing that unless you’re using something faster than ATA-33 correct?

Regardless, the drive is now back on a 40wire cable on a standard ATA-33 controller. Both the quality test and the scan disk ran fine.

Here’s the results for a raw-written SVCD disk that plays pretty much everywhere (my desktop, my laptop, my in-laws JVC player) except on my Panasonic S35:

General Information
Drive: SONY DVD RW DW-D26A
Firmware: JYS2
Disc: Data CD (Princo)
Selected speed: Maximum
C1 errors
Maximum: 548
Average: 1.00
Total: 2702
C2 errors
Maximum: 663
Average: 0.36
Total: 975
Jitter: n/a
Scanning Statistics
Elapsed time: 2:13
Number of samples: 2756
Average scanning interval: 1.04 sec
Glitches removed: 0