Suse Linux internet connection problems

vbimport

#1

Just installed Suse Linux as a dual boot system with Windows XP on an HP Pavilion notebook.
The installation worked well, but I can’t get connected to the internet.

I have a wireless card - I can not find out which manufacturer it is and assume it’s HP specific. It’s broadcom 802.11 and is not supported by Suse Linux - does anyone know where I could find a linux driver for this card… or whether I need to attempt using ndiswrapper?
If anyone has advice on ndiswrapper I’d appreciate some guidance (I’m currently reading a tutorial on it on suseforums.

My internet cable connection is strange…
The network card is NVidia, and is detected by Linux. When I boot up, KNetwork manager is giving a message that a wired network is connected - however I can’t get Firefox or Konqueror to work.
I’ve tried configuring the network card manually, but haven’t been able to connect yet.
Any ideas much appreciated :flower:


#2

check this article out


#3

If the wireless card is a PCI device try running:

‘lspci’

or

‘cat /proc/pci’

This will give you some information about the wireless chipset.

Some Broadcom wireless chips are supported by recent Linux kernels.

If that fails, you can always try Ndiswrapper.


#4

Which one will you be using in the hotel(s), Prof.? The LAN? Not sure why you can’t connect as this is usually set up automatically during install, when using DHCP anyway. You could check the Firewall settings under “Security and Users”, is DHCP Server/DHCP Client shown under “Allowed Services”?

How do you combine wired and wireless at home? Is the cable that you plug into the laptop connected to a wireless router?


#5

Hi again, the wired connection is working fine now that I am living in a hotel room again - in fact I’m posting from my Linux desktop right now :bigsmile:
That means I’ve done something wrong with my home set up…
The network connection is detected, and in fact I get a message that I am online, but the browsers won’t work. I chcked the firewall and the DHCP settings, but couldn’t find anything. I’ll have to wait for about 5 weeks to sort that out before I’m back home…


#6

The wireless card is a PCI device and has a Broadcom 802.11b/g chipset. From the info I’ve been able to find on Broadcom, it looks as it this isn’t supported.
I ran lspci, but it didn’t show much as the wireless card is not even detected by linux, so I couldn’t get any info.
There is always a chance I’m doing it wrong, because I’ve just been doing a crash course in using the commany line, which is all new to me :slight_smile:

@ Cressida - I use a variety of wireless networks including Starbucks, the Toronto network (wireless is free in downtown Toronto) and one at home - this isn’t mine but is an open network I can detect from home (that someone in my neighbourhod has no idea how to set up :doh:) . I’m just using it to see if I can get the netwrok card working.

All a bit academic now, as I’m without wireless for 5 weeks.
It looks like ndiswrapper is the way to go, so I’m going to have to do a lot of learning to get there.
@Slayerking - thanks for links :slight_smile:


#7

Feels good, doesn’t it :bigsmile: ? Don’t let talk about the command line scare you, you won’t need it that much. When installing software, stick with rpm’s for your SUSE version (YaST / Software Management) and everything should be taken care of for you. Resist the temptation to compile source packages yourself via command line (those SUSE people know the ins-and-outs of their system best).

Before typing “lspci”, type “su” (for superuser) and enter your root password (remember as “su-to-root” :slight_smile: ). You won’t get around using NdisWrapper when you get back I think. I have a Broadcom BCM4306 chip in my SuSE 10.0 desktop too. It seems you may first have to “blacklist” the Linux driver to prevent it from loading in SUSE 10.2 though (see link above). Blacklisting is the easier (and safer) workaround for removing it from and recompiling your kernel :bigsmile: .


#8

For reference: http://en.opensuse.org/SDB:Broadcom_(BCM4306)_WLAN_Installation_under_SUSE . The Linux bcm43xx driver included with 10.2 doesn’t work out of the box because it needs the firmware. Oddly there’s no mention of 10.1, but I’m assuming this will require ndiswrapper.

I got my Siemens Gigaset 54g PCI-card working with the bcm43xx driver in 10.2 64-bit (using fwcutter on the WinXP x64 driver for an Acer Aspire 5020 notebook :eek: ).