Subtitles on & off with precision

vbimport

#1

I had found that after editing a DVD the subtitles would be on by default when playing the DVD which naturally I didn’t want. I then hit upon the idea of inserting the command ‘sub-picture = 0 (track 0:OFF)’ as the first command in the root menu. This worked fine and subtitles would now be off by default when playing (although I could then turn them on via the remote as required).

However I now see that this is a little too simplistic because when I turn subtitles on with the remote and then navigate around the DVD (say to another chapter) the subtitles are turned off again. Presumably this is because I’m navigating via the root menu which then reissues the command to turn off subtitles before taking me to the new point on the DVD. I’d like to be able to still have subtitles off by default but when I turn them on have them remain on regardless of navigation until I wish to turn them off again.

I assume this is how ‘well designed’ DVD’s work although I’m beginning to realise that a number of ‘professionally created’ DVD’s may not have good navigation design.


#2

What you’re doing is by direct command. It does not work sometimes as you have encountered. Also, there’s a possibility that when you turned the subtitle off in the root menu, it stays back on when you play the movie.

You’re encountering a situation where the subpicture command is retrieving the value from the register by way of indirect command, e.g. sub-picture = R[x]. The proper way is to find this [I]key[/I] register that holds the nonvalue and change it to 0. Start from first play and trace it through. Don’t change it for all occurrences of this register though, only do it before the menu or the movie starts. Most of the time, you only need to change it once.

There are also guides in different forums for turning subtitles on/off by default but I prefer my way.


#3

Another way is to find the movie PGC and directly before any commands that actually play the title (e.g. “Break”, Link Cell, Link PGN, Link PTT, etc) [B]and [/B]at the end of the precommands, enter your subtitle =0, off command.

This is very kludgy, but will work. Typically, if you want to see the subs, you’ll need to turn them on by the remote (although the language menu should work if a RSM is issued when you resume playback, as this will bypass the precommands). Also, you need to be aware of any streams that the authoring wants on by force (e.g. foreign language speak). Setting a register to 0 will turn these off, too. You don’t want that to happen in The Last Samurai or Dances With Wolves!!!

Regards


#4

Thanks for the helpful replies. I still am left with what may be an insoluble problem. What I want to do (if possible??) is to be able to:

  1. Start first play with subtitles OFF.

  2. If I subsequently turn subtitles ON with remote then when I play any another title the subtitles remain ON (rather than get turned OFF ‘automatically’) unless and until I turn subtitles OFF with remote.

  3. I also want to ensure that after I turn subtitles ON and then subsequently turn them OFF, that they stay turned OFF when I play any other title (rather than stay turned ON ‘automatically’).

I’d guess that if this whole scheme can work it would probably have to rely on using conditional commands of some sort.

I have a zipped very small minisample of the DVD concerned ready to upload. Unfortunately I can’t upload it here because of size limitation.


#5
  1. Almost every commercial DVD will do this, unless you are in a country where the audio is not available in your native language, in which case, subtitles in your country’s language are usually turned on by default along with say English audio.

  2. When you press the subtitle button on your remote, it acts as to cycle through the available streams. The title’s post commands might (or might not) turn the subtitles off after the title is finished playing. No way to tell 100% for sure, except by analysing the command structure of the DVD.

  3. Again, this is true for almost every DVD. However, some DVDs have titles where subbies are turned on. And caveat this with the foreign language scenario set out in 1.

As far as posting your DVD, you need only post the IFOs, the VOBs are irrelevant.

Regards


#6

OK. I’ve attached the IFO’s for the DVD in question. I’m still puzzled how subtitles could come on ‘automatically’ even where there are no subtitle commands at all. I removed all subtitle commands and subtitles still were on. Perhaps the default (which is embedded somehow in the DVD or is in the firmware in the player) is to have subtitles on but these are normally ‘supressed’ by subtitle commands which are written as a matter of routine by commercial DVD designers.

Kin Kon IFO’s.zip (1.79 KB)


#7

Are you testing this in software player, like PowerDVD, or in standalone? PowerDVD6 turns it on automatically no matter what you do.

It could be that the subtitles are forced. Load the DVD in DVDSubEdit and check that the subtitle’s Start command is forced. If it is, there goes the mystery.


#8

I’m surprised it plays at all - the FP-PGC has an illegal command. You need to set the Title number. Also, we have no idea what the buttons in VTS 1, Root menu do.

Please also update your DVDRMP - it is well out of date (your version was released in mid 2006!!!).

Regards