Subtitles on certain movies

I’m using DVDFab 5.2.3.2 with great success so far. LOVE the software.

I’m having trouble with a couple of movies with regards to subtitles. Usually I only check “Display only forced subpicture” and under Conversion Settings, i’ll pick “Direct render to video” (if available).

I use DVD to Mobile (Generic). I copy the files to my HP Windows Home Server with Twonky streaming to my PS3.

The last 2 movies I had trouble with were French Kiss and Star Wars: The Phantom Menace. In French Kiss, I want to only see the English subtitles when the actors are speaking French (the default action it seems when I play the DVD in any player). In Phantom Menace, I wish to see subtitles when non english is spoken (also the default i’ve experienced in several of my DVD players).

What’s the trick to this? There seems to be some inconsistency since I have been able to get some movies to show normal subtitles correctly. For example, yesterday I did “Goonies” and that movie came out fine.

I’d appreciate any advice. My previous results have been: No subtitles whatsoever, or the whole movie has them.

Thanks

Hi,
You might try under changing a couple of options under “Crop Settings” :

  1. Select “Supported By Device”.
  2. Select “Customize” and then change the “Bottom Crop” settings to zero.

I was experiencing the exact same problem and after many trials and errors this finally worked great for me. Also, you have to select English sub-titles on the first screen.
Hop this helps!
Fred

If the subtitles are really forced, the checkbox will get them if you select the correct subpicture stream that contains them. In some movies, the translations are in a stream by themselves that is controlled by default selection on one of the menus and don’t have forced start commands in the VOBs (so the checkbox won’t work). And the subtitles sometimes don’t render properly if you select a very large screen size for the conversion. Try tinear’s workaround, it might work for some of the ones you are having problems with (but you will encode a black bar at the bottom of the screen). I have Phantom Menace somewhere and will try it to see if I can get them to display correctly.

Cool thanks for the suggestions. I’ll keep that trick in mind. It didn’t pan out for French Kiss but it may for Star Wars (when I can find my temporarily misplaced disc).

So far it’s just hit or miss… for example I just did The Hunt for Red October and the subtitles for Russian dialog worked fine. Woot.

:slight_smile:

The Russian->English in Red October is not forced, it is rendered into the video during mastering, so it’s not a good test. Still looking for Phantom Menace. Vantage Point has real forced subs. If you work with subtitles a lot, get DVDSubEdit (free), an excellent tool that allows you to quickly find forced subs, make subs forced, make them unforced, change colors, position, transparency, timing etc. Here is a link to the homepage: http://download.videohelp.com/DVDSubEdit/

Signals,
Thanks for the info on sub-titles and the utility download!
It’s just what the doctor ordered…
Fred

You’re welcome! We should all thank [I]jeanl[/I] for DVDSubEdit and FixVTS.

Good point on the Hunt for Red October, I can see that it’s rendered into the video.

The DVDSubEdit worked perfectly, I used good ol DVD Decrypter to get the .VOB files from French Kiss and VIOLA I got the result I was looking for.

Thanks for the tips. :bow:

The only certain thing with subtitles is that the next movie will do it differently. That’s why I find DVDSubEdit is so handy to have in my toolbox. There are good guides for it also.

@Messalina
I have found my copy of New Hope but still looking for Phantom Menace.

[quote=signals;2239428]@Messalina
I have found my copy of New Hope but still looking for Phantom Menace.[/quote]I finally found Phantom Menace. The subtitles are unusual but should copy fine with DVD to Mobile.
On the Title selection page, select “Title1[1]” for the video, and select the middle English subpicture stream (NOT the top one). These are forced subtitles that fade in so they look a little strange when rendered. You do not need to check the Display only forced checkbox, the only ones in the stream are the forced ones. See attached.