Subtitle issue

vbimport

#1

This is not an AnyDVD question, but I didn’t know where else to post it. I apologize for this.

I ripped a copy of A Woman Called Golda (1982) to disk (using AnyDVD 7.6.1.0) and had no problems. I noted that none of the menus of the film mentioned subtitles. Subtitles are very important to me (I am deaf) so I (as always) made sure that subtitle transparency was set to 15. I played the resultant disk DVD files using VLC Media Player 2.1.5 and was able to see and read the subtitles without problems.

I then tried to use DVDShrink 3.2 to edit the film, but DVDShrink reported “no subtitle stream”.

Next, I tried CloneDVD2 2.9.3.0 and it showed no evidence of the existence of subtitles.

I note that VLC Media Player has a right-menu function to control subtitles while neither of the other two programs have such a control (so far as I have found) to control subtitles.

Has anyone else had this problem. Is there a way around it?

pilgrim


#2

What kind of editing were you trying to do with DVDShrink? It wouldn’t be my first choice for editing.

Examine the ripped DVD with PGCDemux. See if you can extract the subtitle stream with it.

Do you want to keep the original menu, even though it doesn’t seem to mention the subtitles? Or do you want to make a new version? You can make a new one that is either re-encoded to a smaller size, or keep the original size and quality.


#3

Could the subtitles be hard coded ?
Meaning they will play & can’t be turned off .
If they are the all your computer media players should play them.

Programs like DVDShrink or CloneDVD2 might not detect those.
Since they can’t be removed.

If you have a DVD RW you could do a test burn to it & see if your standalone DVD player will play that DVD with subtitles.