Sub titles

i can’t seem to get rid of them when ripping to mobile generic…

what am i doing wrong?

Not sure, but you may be leaving one of the subpicture boxes checked on the first DVD to Mobile page, in the lower right (before you click Next). All of these should be UNchecked if you don’t want subs in the output.