Stupid Question

vbimport

#1

But I have to ask it since I can’t find the answer anywhere.

I have a liteon CDRW drive that when I put a CD just ejects about a second after. It stays closed when I do not have a cd in there but as soon as I press eject it opens… allows me to put a cd in… i press eject again and 1/2 a second later its opening the cd rom drive again.

I’m sure this is something easy or whatnot but I’ve never come across this before and I may have made matters worse. I assumed this to be dust or whatnot and took a can of compressed air and blasted into the drive while it was ejected.

Does anybody know what this might be? My next step is probably to take the entire drive apart and make sure there is no dust inside.

For the record this appeared to happen at around the same time I installed a DVD RW … which seems to work fine.

Any help would be greatly appreciated.


#2

If possible, take the drive out of your computer and put it in anothers, and see if it works there. It could be a software problem.


#3

I can try that because I have several drives but this happened in RH9 and since I have swap HD’s I’ve tried Free BSD and Windows XP and I get the same thing. It definitely “appears” to be hardware based. I read somewhere on the net that this happens when the laser cannot read the disk. IE - if too much dust is in there.

I was just trying to confirm this fact in a more reputable environment. :slight_smile:


#4

If the lens is dusty it might be worth trying a CD lens cleaner.


#5

tried that too my friend. Well… at least one of those CD lens cleaners but the rom kicks out too soon for anything to happen.


#6

The CD could be catching on something inside the drive itself.


#7

Have you tried a new or different IDE cable yet?
Tried on a different IDE channel yet?


#8

I’ll try a different cable and a different IDE channel.

I’ll post whatever I find out in here.

I suspect its what Cyber says… that its catching on something inside the drive or whatnot.

I’ll keep you posted.


#9

When did you get the drive?

You can pull it apart and see if there is anything, but i’m pretty sure doing that voids the warranty of the drive.

What Model is it?


#10

I’m not worried about the warranty… It’s a liteon… I got it awhile ago now… maybe a year maybe not. I’m not really sure. It’s been a great burner and I don’t want to let it go :slight_smile:

I’m willing to take it apart and see whats going on. :slight_smile:

Thanks Cyber.


#11

I’ll let you know the model as well… I’ll post it up in a bit. Sorry for not putting it up earlier. I thought someone might have heard of a CDROM doing this before and it was a hardware thing.

I’ll post up info.


#12

Ok, its a Lite-On LTR-24102B.

CDRW 24x10x40x

I got it about a year ago. It was working fine until it failed in the middle of X roast (linux burning program) and I being an idiot trying to eject the cd and since it wouldn’t open I held the button in and kept hitting it etc until it came out.

It could very well be software. I’m going to try a different IDE cable and see how that goes right now.


#13

It’s not the IDE cable… its now the only CD device on my comp. It’s on the secondary IDE channel. I’ve tried it as master, cable select and slave with another drive present as the master.

I’m at a loss. It just keeps ejecting every CD I put in. The system recognizes the drive no problem and yet I can’t read anything because it keeps kicking out. Any help is appreciated.