Stumped by DMA / PIO issue

vbimport

#1

Hi everyone,

I recently replaced my DVD burner with a Lite-On DH-20A4P burner; at the same time I added a Lite-On DH-16D2P ROM to the bottom bay (previously unused). Jumpers are both set to cable select. Both drives are new.

The bottom drive (the rom) had garbled, choppy playback on both DVDs and CDs, originals and copies both. Thinking it was a defective drive, I swapped them around. It plays fine on the top connector.

Investigating further, I found that my Secondary IDE Channel, where both drives reside, is as follows: Device 0 (burner): Device Type: Auto Detection (greyed out); Transfer Mode: DMA if available; Current Transfer Mode: Ultra DMA Mode 2. On Device 1 (the ROM) however, the current transfer mode is stuck on PIO. I think that may well be my audio problem (but I’m open to suggestions!) I’ve been messing with it for 2 days, and run out of ideas. This is what I’ve done so far to get it back into DMA mode:

-First thing, obviously, try and reset thru the buttons on Advanced Settings
-Uninstalled drivers
-Used reset tools from Dell, Microsoft and one other place I can’t remember
-Deleted registry keys for Master & Slave IdDataCheckSum
-Changed the jumpers to Master/Slave from Cable Select.

Of course, after every change I rebooted. Always backed up the registry, etc. Nothing worked. When I changed the jumpers to Master/Slave, neither drive was recognized, I had no secondary channel, just my lone HDD sitting in the Primary. I put it back to cable select.

I must have taken the drives out 10 times. Everything’s clean and securely seated. I’ve run out of ideas; I’ve read references to BIOS adjustments, but I’ve never done one before and would need to be helped through it.

Specs: Dell Dimension 2400/Celeron 2.4mghz/80GHDD/1.2G RAM/Windows XP sp2.

I’d greatly appreciate any ideas

Thanks,
Karen


#2

i am confused how do you put two drives and a hard drive on the same ide? You say you don’t have a secound channel :confused: I know if you do put a hdd with a opitcal drive it causes trouble. Hmm, what type of ide cable are they on? an one with 40 bigger wires or 80 smaller ones? because you’d want the one with 80.


#3

Right click on the secondary channel in device manager & uninstall it, then reboot. Here’s an article a friend supplied a link to a while ago.

DMA


#4

@Matthew,

Sorry if I wasn’t clear; my two DVD drives are in the same secondary channel, the hard drive is in the primary. My cable is the one that came with the computer; to be honest I don’t know how many pins it has, but the connectors fit in perfectly to the backs of the drives.

@beef,

I tried that early on and it didn’t work. That’s why I thought this might be a BIOS thing.

Thanks for your replies!

Karen


#5

I agree with Matthew12222 Replace your cable, 40 pins 80 wires, that old of a dell came with 40 pin 40 wire cable.


#6

First thing, obviously, try and reset thru the buttons on Advanced Settings
-Uninstalled drivers

Did you uninstall the channel or the drivers or have you tried both?


#7

beef, I did both.

I may have solved the problem; in BIOS the secondary slave drive was set to “off”; I toggled it to Auto and DMA is back. Don’t quite understand that, as the drive was recognized.

I’ll look into replacing the cable, tgidday.

Thanks very much for your help.


#8

There are a lot of different bios screens so it would be rather difficult for someone to tell you exactly where to go in the bios. If you are carfull, you can go poking around yourself and find it (probably under advanced setting option or something like that). The important thing is, when you exit the bios, it will give you the option to save and exit or exit without saving. You defenatly want to exit without saving in case you accidentally changed any setting. As long as you dont save changes, you wont hurt anything. Once you find dma settings, you can exit, then go back into the bios, go right to those settings without messing with anything else, and change them, then save and exit. If you are still unsure, find the settings and tell us what the options are in the bios and we can help further. Fyi, if it lists primary and secondary channel and or slave an master seperatlly, check them all. Windows can sometimes falsely report a drive that is running in pio mode as running dma2.

On the cable thing, all have 40 pins that connect on the end, but some have 40 wires on the cable and some have 80 wires. You can actually carefully count how many wires you have on the cable. You want 80.

Opps, saw you got it fixed (posted at the same time). The drive will be recognized and run fine in pio mode, it will just limit the speed at which the drive can transfer data to or from the computer. Pio mose is to slow for many things.


#9

Ripit, thanks for your reply. It seems that may have been an issue previously with Dell and Lite-on drives; there’s a firmware update for an older Lite-On cd-rom drive on the Dell site; the secondary slave would automatically go to PIO.

Just a comment on my BIOS adventure; it’s something I approached with great trepidation, believe me! However, I didn’t see any option or prompt to save changes…just escape and the computer continues to boot. In that case I guess it would pay to write down every change I made. Don’t plan on that for the immediate future, though!

Thanks!