Stretched Audio in VOB

vbimport

#1

Greetings people,

for the past few weeks i’ve been having the same problem:

I convert AVI files to VOB files with NERO VISION EXPRES, and then burn them to a DVDROM with NERO.
The only problem is that, after i converted the AVI to VOBS, the audio isn’t synch.

It’s ok in the beginning, but after a while, the audio is ahead of the movie, so i hear voices, even before i see the mouths move.

I know this is called stretched audio, but HOW DO I FIX IT.

Please help.

Maik


#2

Normally I do sound manually when converting to DVDs to avoid these kind of problems.

Here’s a short guide:
**** You’ll need about 8Gb of free space to do this ****

VirtualDubMod - Demuxing (extracting) audio
http://virtualdubmod.sourceforge.net/ - Latest
WinAMP + Disk Writer Plugin - Converting to PCM (Uncompressed audio)
http://download.nullsoft.com/winamp/client/winamp281_full.exe
SSRC - Converting samplerates (if needed)
http://rarewares.hydrogenaudio.org/others.html - Shibatch sampling rate converter compiled with ICL for speed
tooLAME - Encoding PCM to MPEG2
http://www.doom9.org/ --> Download --> Audio Tools --> show all audio tools --> Toolame 0.2k
TMPGEnc Plus - Encoding AVI (video only) to MPEG-2
http://www.pegasys-inc.com/en/download/index.html
TMPGEnc DVD Author - Muxing Audio+Video and creating VOBs
http://www.pegasys-inc.com/en/download/index.html

  • Open AVI-file in VirtualDubMod
  • Streams --> Stream List --> Mark audio stream (Check if it’s 44100Hz or 48000Hz) --> Demux --> Close VirtualDubMod
  • Open WinAMP --> Ctrl + P --> Plugins - Output - Nullsoft Disk Writer --> Configure --> Check “Convert to format” and select “PCM 44100Hz or 4800Hz. 16 Bit, Stereo” (Set the same sampling rate as vdubmod reported) --> Close all windows --> Add file into playlist and play it --> Change output plugin to DirectSound when WinAMP has stopped.
    ==== Skip the following step if your sample rate already is 48000Hz ====
  • Open up a command prompt, go to the directory where ssrc is stored and type the following syntax (without quotes and remember to change paths):
    “ssrc --rate 48000 --two-pass --normalize d:\path o\my\unresampled\pcm\file.wav d:\path o\my\unresampled\pcm\file_resampled.wav”
  • Once ssrc done go to toolame’s directory and type:
    “toolame -s 48 d:\path o\my\unresampled\pcm\file_resampled.wav d:\path o\my\unresampled\pcm\file_resampled.mp2” --> close cmd window when toolame has completed its task.
  • Open TMPGEnc Plus --> Choose approperiate type of DVD in the wizard (Ctrl + W if it doesn’t pop up) --> select CBR MP2 as audio --> Set audio bitrate to 192 at page 4/5 and crank up avg video bitrate --> Uncheck “Start encoding immediately” --> Change stream type to ES (Video only) and press start --> Close TMPGEnc when it’s done encoding
  • Open TMPGEnc DVD Author and follow the wizard --> add video (m2v) and audio (mp2) --> Burn :slight_smile:
    //Danne