Strange Windows (I think) behaviour

Strange behaviour.
If I leave my P2p to download all night (with my ADSL), in the morning I can’t navigate (but the P2p continues to download). I’m quite sure it’s not a router or ADSL problem, because if I restart the router (so it disconnects and then reconnects to the Internet) the problem still persists.
The only way I can solve the problem is….restart Windows! If I do so, I can navigate and download at the same time again.
So I think the problem is software related.
What can I do to solve the problem without the need of restarting the O.S.?

Two things you can try.

  1. Turn off your windows firewall. (not recommended if you have a USB modem).
  2. Download the EVILID patch for tcpip.sys to allow more half open TCP connections under winxp SP2.

Thanks for the help and link to the prog.!

Keep in mind that program will likley show up as a PUP with antivirus. The program is harmless and the warning can be ignored. Been there done that :smiley:

Thanks mate. Fortunately my NOD32 antivirus rightly didn’t expect that was a virus. Anyway thank for the “warning” :slight_smile: .

May I ask which value do you use? I’ve put the 50 standard value, but the problem still persists :doh: .

I just want to give a further confirmation that is a Windows problem and not a router or ADSL problem: when this morning I tried to surf into the net I couldn’t (the browser gave the same error like if it couldn’t find the page), but when I tried on the second PC which is connected to the same router I could navigate without a hassle :confused: .

What happens when you repair the network connection? & Flush the DNS cache?

Can you delete your network adapter & then reinstall?

50 works just fine. put in 100 or more either your router or system will crash.

ps: a PUP is a pontenitally unwanted program, not a flagged virus. not all av programs sniff out pup’s. Mcafee does.

I was just thinking that Debro: His system could be filling up all those nice temp places so a reboot cleans things up

So I should deduce that Mcafee is better than Nod32 from this point of view becouse it reveales PUPs and “wrongly” shows EVILID patch as a PUP :stuck_out_tongue: .

Not at all. Not every AV progam is going to catch everything. I run the on-line Trend micro scan once in a while and it usually spots some old long ago diabled bug. It just catches the signature or the name. As I recall the last one it found was from 2002. Long dead but still there.

I’m sorry, but I don’t know what are you talking about (becouse of my limited knowledge).
How can I " repair the network connection? & Flush the DNS cache"?

Interesting, is this on-line Trend micro scan free?

yes

http://security.symantec.com/sscv6/home.asp?langid=ie&venid=sym&plfid=23&pkj=ZSUIHODEQOHBDJQEEFG
http://housecall60.trendmicro.com/en/start_corp.asp


http://www.kaspersky.com/virusscanner

http://www3.ca.com/securityadvisor/virusinfo/scan.aspx
http://support.f-secure.com/enu/home/ols.shtml

Owow. That’s a huge list, thanks :wink: ! Now I’ll spend some time scanning my system. But returning on the matter of the post “How can I repair the network connection? & Flush the DNS cache"?


Flush DNS:

Start->Run
"command"
“ipconfig /flushdns”

Repair:
The short way:
Double click you network icon on the system tray
"Support" Tab->Repair

The long way:
Start->Settings->Control panel->Network Connections.
Double click your network connection (not your firewire connections)
“Support” Tab->Repair

It’ll just force windows to re-check it’s connection.

Thanks for your help debro! :slight_smile:
I’ll try this tonight and in the morning if the problem remains.

You can also reduce the number of simultaneous connections & also reduce the maximum number of connections in your P2P software.

Reducing it to 50 (same as the EVLLD patch) would be best.

I use uTorrent for the Bittorent P2P. In settings – Torrents there is

  • Global Maximum Number of Connections: (now it’s set on 200)
  • Maximum Number of connected peers per torrent: (now it’s set on 50)

So, If I’ve understood I should set 50 for both of them (of course the number of connections made to the torrents will be limited, and I may lose some downloading speed).

My personal settings:
Global: 50
Max peers per torrent: 30ish.
But I limit it to 4 concurrent downloads (when the program chooses to regard the limits).