Strange rebooting problem

So I recently installed a Silicon Image 0680A PCI IDE controller card in my old computer and it mostly seems to work fine. The trouble is, when I have all my IDE channels occupied on the motherboard (Asus P4P800SE), and my eSATA external hard drive plugged in, the computer gets stuck in an endless reboot cycle.

The following scenarios cause the computer to boot normally again:

  • If I unplug everything from the SiI controller card, and plug in the external HDD as eSATA
  • If not all the IDE channels on the motherboard are occupied, and plug in the external HDD as eSATA
  • If I plug everything in, and plug the external HDD as USB instead of eSATA

Currently, I’m using scenario number 3. So, this is basically only an annoyance at this point that I have to use USB instead of eSATA for that particular computer as the eSATA functions proper on other machines. Just wondering if anyone had any ideas to get this running more smoothly.

What BIOS and driver version are you using for the IDE card? Also what O/S are you using? I have the similiar card in my system and have updated the BIOS and software drivers. But that is dependent on what O/S your using. Also does your computer boot correctly when nothing is connected to the card and nothing plugged into the eSata? How do or what pci are you using the card in? What kinda computer and motherboard do you have? So did you like remove your internal HDD and put them into the external HDD?? What do you currently connect to the IDE controller card HDD or something else cause you don’t mention what you have plugged into the addon card?? Just from the looks of it sounds like what ever is plugged into the addon card is a bad HDD or IDE hardware that is failing…but that will depend alot on what BIOS and driver your using for your addon card. So at this point a little more specs is needed…???

It’s not the OS. It doesn’t even get that far. I’m using base BIOS 3.3.08. My mobo, as previously stated, is an Asus P4P800SE.

My configuration is:

primary mobo IDE channel - 2 HDDs
secondary mobo IDE channel - 2 ODDs
primary SiI controller channel - 2 ODDs
secondary SiI controller channel - empty

and then if I plug my external drive into my eSATA port (which is wired to onboard SATA port) it won’t boot.

And to answer your question: yes, if all I have plugged in are the mobo IDE channels, the computer boots up.

[QUOTE=Saucerful;2472176]It’s not the OS. It doesn’t even get that far. I’m using base BIOS 3.3.08. [/QUOTE]

How current is your mobo BIOS? Also you might want to update your silicon BIOS as well. Cause from what it sounds like something is not communicating right and is causing reboots. Also when it does bootup screen checks does it see the ODD attached on the addon? I for one having that same chipset card haven’t had any problems with my mobo is also a Asus but different mobo its a M4N72-E. Both exist and work fine together both also both have latest BIOS updated as well. If you had nothing attached to your card you said work correctly and when you plug those ODD on the card it doesn’t work. That would tell you to at least see if your ODD is still working correctly. Cause I know a older ODD attached to my silicon makes my computer some time to reboot so now that I took it out and left my IDE HDD attached to the card it works ok. I think also be good to know how old your hardware is as well could be they are no longer operating correctly or can’t work correctly with your Silicon card. My silicon is using 3.4.0 BIOS.

It wasn’t really intuitive to me about the drivers and BIOS on the SiI site. I’m using the 1.2.30.0 driver as I’m using XP Pro SP3 and the only newer driver than that is for Windows 7. I’m wondering if the newer 3.4.0 BIOS breaks compatibility with XP.

edit From the SiI website: “For best results, use the releases of BIOS and management tools recommended for the driver on the driver download page.” The 1.2.30.0 says to use the 3.3.08 BIOS.

Assign a different IRQ to the card in bios.
Or move the PCI card to a different slot.

Also, when you plug in your Esata drive, it’s logical assignment may be lower than your boot drive, so the bios checks that first, can’t find any boot info & reboots.

Or possibly … the bios detects the drives correctly and boots from the correct drive, but windows loads the driver for your sil controller first, assigns your esata drive as the primary drive & falls over. God knows what sort of weird bugs windows has :stuck_out_tongue:

I know that windows craps itself if there is any partition corruption, or it can’t read a partition correctly, especially a problem when I’m switching around drives with mixtures of linux EXT2/3/4 partitions and windows NTFS/Fat32 partitions and windows expects a particular logical device & partition to be something (NTFS/FAT32), but it turns out to be something else (EXT2/3/4)

I will try these suggestions when I get home.

Also, has anybody here tried BIOS 3.4.0 with Windows XP? Can I flash back to 3.3.08 if it doesn’t work? I’ve been using the DOS flash tool.

I know 3.4.0 works cause before switching over to win7 I also had XP pro SP3 on my system. So I know it works as you mentioned just get the latest drivers for your O/S since XP. But I would say dig into your owner manual and check to see if you do have the most current mobo BIOS and look through it bootup process and see what you can change to make sure it is following the correct bootup process. I think you can’t flash it back 3.3.08 once you flash it to the newer version cause the flash program would see it was a older BIOS your trying to flash to and it will either stop or tell you the current BIOS is the newer and won’t flash with the older BIOS. But I think you should check over your mobo BIOS cause I think the conflict is starting there.

Looks like I’m one BIOS behind on my mobo. I’ll try that first. If that doesn’t work I’ll mess with the IRQ settings in the BIOS, then maybe flash the SiI BIOS to the newest one.

Well I solved my problem.

First I flashed my mobo BIOS to the newest, and that didn’t help. But, it can’t hurt having the newest BIOS.

I also tried flashing the card to 3.4.0 base BIOS and although that didn’t help my problem, again it can’t hurt having the latest. Also, it is like a previous poster said, 3.4.0 does not break compatibility with the XP drivers.

Lastly, I tried fiddling with the IRQ settings and found one that worked. Must have been a conflict. Everything works now regardless of what configuration I use for my drives.

Thanks for all the suggestions!

IRQ conflicts are a nasty bug sometimes it tells you sometimes it doesn’t. Glad you found a IRQ that worked. But it’s true having the latest BIOS or Firmware doesn’t hurt even if it doesn’t change but sometimes in case of mobo it does give you more option when you needed it later on. As for the addon it helps in the sense that it will improve the interface with your mobo.

[QUOTE=Saucerful;2472665]Well I solved my problem.

Lastly, I tried fiddling with the IRQ settings and found one that worked. Must have been a conflict. Everything works now regardless of what configuration I use for my drives.
[/QUOTE]
Resolving IRQ’s is a faded skill as newer motherboards have generally expanded the qty of IRQ’s over the original 15, and new devices have generally programmed better handling of IRQ requests & conflicts.

I guess we can add another company to the list of bad programmers … Creative (soundblaster) are no longer alone on the list!