Strange problems with NEC ND-2500A

I’m having some rather odd problems with my new DVD burner. I’ve read the other threads which contain some of my problems, but there are also some extra ones which I have.

Firstly, the read speed of my drive leaves a lot to be desired. I can only read dvd’s at 2x speed, and that’s both DVD-Video’s, and Data DVD’s which I have burned myself. I’ve read before that the OEM drives are locked to 2x, unless you change the firmware. I’ve tried the two firmwares which were backed up and posted by pdc in another thread (rpc1 + rip-speed, and rip-speed only), and both give the same results. I have yet to try the ones provided by The Dangerous Brothers, but I presume these are exactly the same as the one’s in pdc’s signature.

Secondly, the burn speed of my drive is also very slow. I’ve tried to different types of 4x media (Bulpaq and Mirror Platinum), but it always takes me 45 mins to burn a 4.3GB DVD (which I think is about 1.5x speed).

Thirdly, whenever I burn a DVD, it never reports the correct size for the dvd when I select the disc in My Computer and it shows the dvd capacity. Even though the disc contains 4.3GB of data (and some other large sizes from other dvd’s I’ve made), it always reports the size of the DVD as 1.99GB. I find this problem rather odd, and can’t understand why it can never calculate the correct size.

I hope someone can help me or tell me what I’m doing wrong, because it’s getting very frustrating now.

I’ve tried enabling DMA mode for my drive hoping that may give it a speed burst.

Could it be my PC’s spec? I currently have the following :-
PIII 600MHz
192MB RAM
40GB HDD, with 15GB free (drive speed = 4,717 KB/s)

I realise that I have a slow hard drive, and that would account for some of the slow-down when burning (although, 4,717KB/s is still about 3.5x speed, yet I can only burn at 1.5x speed), but would this also affect the read speed? I’ve benchmarked the drive using Nero CD-DVD Speed, which just checks how quick it can access the dvd, and it’s always less than 2x speed.

I would be very grateful for any help in this matter.

One of the problems should be your drive speed. Since you wrote that your drive can do only 4,717Kb/s i’m sure that here we have a problem for sure. Burning dvd’s at 4x require 5,700 Kb/s of sustained drive transfer. I certainly wouldn’t even try to burn a dvd at 4x if i have at least 8,000 Kb/s sustained data transfer.

I think that the burning speed time could be explained by this:
Your drive does not fill the buffer fast enough and your burner is constantly avoiding buffer underrun so it is basically doing Write/pause/buffer refill/write/pause/buferr…

Try burning a DVD at 2x and leave the pc alone when doing it’s job. The burn time should be around 30Min but not over 40!
If this will happen, i see a new, faster drive in your near future.

And for god sake… ENABLE DMA transfer on all devices that supports it.

The only speed that Nero allows me is 2.4x, so I’ve always been using that, and it still seems to have trouble. But the write speed wasn’t my main concern, it was the speed at which it reads (max of 2x on any DVD media) and the fact it always reports the size of the created DVD as 1.99GB. Very weird.

It reads and write’s normal CD-R’s fine in the drive, it’s only the DVD read that’s causing me some problems.

I’ve solved the read/write problems I was having now. It’s not quite as fast as it should be, but that’s always to be expected. It’s performing a lot better now.

The only weird problem I have no (well, not really a problem), is the fact it always reports the size of my newly burned Data DVD’s as 1.99GB, when they are in actual fact a lot bigger. It’s not really causing a problem, I just find it very strange and I can’t think of a reason why it should do so.

I’m glad it worked for you. Btw what was the cause? Did i guessed right?
As for the only left problem i think it is the normal Win9x of if you prefer FAT32 file system that is unable to write/see files bigger than 1.99Gb.
It is not an error but it’s a file system (FAT 32) limitation.
If you want to “resolve” this try Win2000 (or XP but i don’t reccomend) and convert your drives to NTFS. Beware that NTFS formatted drives are slightly slower comapred to the FAT32 format. However you can make, write, see files of any size.

Yes, you were right. It was the DMA. I’ve recently reinstalled the OS, and had forgot to turn it on for my hard drives. I’d turned it on for my writers, but since the hard drive couldn’t read the data that quick without DMA, it made turning DMA on burners have no effect. Plus, when I turned DMA on the one HDD, it didn’t like the fact that I had 2 partitions for some reason, had trouble accessing part of the drive, and resulted in it creating lot’s of bad sectors. Now i’ve merged back to 1 partition, and marked the bas sectors in scandisk, it’s working at a better speed now. Now all I need is some decent DVD media so that I can burn at more than 2.4x speed.

As for the 1.99GB, thanks for clarifying that. I am running Windows ME (probably the only person in the world who prefers this OS to any other :-), he he), so that’s what it would be then.

Cheers.

I thought Fat32 is 4GB’s not 2?

Umm, yeah. Fat32 limitation is 4Gb -1byte. FAT16 has the 2Gb -1byte limit. Since your drives do like 5Mb/s could be that they are formatted as FAT16. IIRC 4.3Gb - 8.4Gb drives had such performance. Btw what drives you got?

Iv’e seen some ppl actually using winme but you are the first that likes it.
I strongly reccomed you to get rid of that joke which pretends to be an operating system and get another one. I reccomend Win2000 just because (forget XP):

  • Fast
  • Raliable, stable
  • Constantly updated
  • Still widely supported
  • All software works on it
  • Very good for gaming too :slight_smile:

In case you wonder i am a pc technician/engineer (job) and video editor NLE (hobby).

P.S. WinMe makes your hardware cry.

Both my drive’s are FAT32. Haven’t used FAT16 in a long time.

Win2k is actually my favourite OS for stability, it’s just really hard to find device drivers for my hardware that work properly with 2k, plus the fact it won’t let some of my old games run at all (Quake2 with my favorite MOD for 1, and Commando’s, to name a few). As for XP, I like the GUI, but that’s about it. I don’t particularly trust MS to make an OS which doesn’t contain lot’s of spyware and security flaws, and I deffinately won’t be switching to Longhorn when it’s out.
When I have the money to build a new, better pc, I’ll stick with good ole 2k, maybe dual booted with ME for my old games :slight_smile:

Well i like some old games too. Try syndicate on Win2000 :confused: :rolleyes: :Z. Then i found a motherboard and a celeron 566, some ram a 4.3Gb hdd a floppy a blazingly fast 8x CD-rom that still works and a creative 16 ISA sound card. Paired with win98 works like a charm for old games. And for those picky - shut down in “dos” always work.
Not the cheapest solution but better than WinMe option.
Btw, whats wrong with Win98SE? I still like them.