Strange problem with ND-2500A and burning DVD+R DL discs

vbimport

#1

Hi, I have an odd problem with my ND-2500A burner (I know, old burner :frowning: ). I was burning a dual layer DVD+R as a data disc using Nero 6. It finished without any error messages and the burn was a success. However, the same DVD burner I used to create the data DVD did not recognize the disc. The drive did try to read it but in the end, it’s as if no disc was inserted.

Now, I took the disc and put it in my laptop’s DVD drive (about a year old), and it worked. I could view the contents of the DVD. I also tested it on a friend’s computer and it worked as well. I have tried to burn another DVD but same problem.

How is it possible that a DVD burner cannot read what it created, but yet it works on other drives? By the way, my ND-2500A was using Herrie’s firmware version 1.08v3-2, and the bitsetting for DVD+R DL was set to DVD-ROM. DVD burner working in Ultra-DMA mode 2. Also, NeroInfoTool shows the drive should be able to read DVD+R DL discs. Again it’s a read problem not a write problem (well according to Nero). Regular DVD±R’s read/write work fine, just the DL problem. Any help in solving the problem would be appreciated.

Thanks.


#2

Your drive should be an ND-2510A to be able to burn DL, the ND-2500A is SL only. Why don’t you try with a more recent firmware. Note Verbatim discs are the only DL worth getting.

Welcome to the Forum.


#3

I think your best bet would be to use Liggy & Dee’s modded firmware for the 2500. What you have is quite old & won’t recognise some of the newer media.

Go here and use Liggy’s NEC 2510 bitsetting firmware 2.19.

This is based on a very recent release from NEC to include much of the newer 16x media.

Other 2500/2510 users have been well pleased with this firmware.