Strange problem with LITE-ON SOHW DVDRW 1633S

I have worked with it perfectly for about 4 month burning CD’s and DVD’s
And now for some reason it stopped reading and burning DVD’s,
But its still reading and burning CD’s perfectly.
It can’t read DVD’s it burned itself and it can’t read original DVD’s of games and movies that worked ok before.

Thenks.

Welcome to the forum.

Try to reflash firmware. Sometimes it solve problems. Anyway when my 1633 begin to have strange behaviours after few days was definitely broken.

flash to 1653 csom or csop

try cleanning the lens!!!

I’m having the same problem. I have a digitalmax drw-3s163 which I’ve flashed to a liteon sohw-1633s. And its worked great for almost a year now and out of the blue one day it stopped reading and writing dvds with no problems to cds.

I just reflashed it with bs41. Which is what I’ve been using. And still its not work. I put a cd lens cleaner in but it would not run. Like it was a dvd, it acts like no disk is in. But cds are still working even after I just flashed. You wouldn’t know where to find firmware for 1653

In my opinion your drive is broken.

It’s time to RMA (or buy another)

Anyway, bs41 firmware was rapidly removed from liteon site because of many problems in it. Try to use newest firmware BS0S to see if it solve your problems.