Strange & annoying capturing issues

vbimport

#1

Hi folks
I’m new here, though have been reading here a while, learning quite a bit.
No sense beating around the bush, I figured I’d make my first question a goodie.

I thought I’d pick your collective brains for this unusual capturing problem. I’ve Googled high and low, and only found one reference to the same problem, and no one answered this persons query.

So, on with the problem:
I have been capuring with a Hauppauge PCI card for quite a while now, from two different scources - VCR (transferring old home movies) and dish.
I capture in DVD quality, 640x480 size.
Sometimes when I capture my video, the computer will lock up. A hard reboot from the front panel is required. The mouse won’t move, though I still hear the audio as it plays. Time seems to vary for this to occur…it may happen 15 min from the start, maybe 1h45m…never the same time interval.
Sometimes after a “successful” capture, during playback the video pauses for <1 second, then a few seconds later the audio will pause for <1 second, then a few seconds later the video pauses again - this cycle continues for the length of the capture (captures from a few seconds to over 2 hours…it doesn’t matter). This is in the video, as it occurs in all video players. Editing the capture doesn’t change this, ie: cutting a piece and saving it, the edited piece still pauses the same. I can’t tell it’s doing this during the capture, as the preview doen’t display it. I have to wait till the capture is COMPLETE before I’m disappointed. :sad:
Rebooting sometimes helps the pausing thing, as re-capturing after this problems usually means it will re-occur.
Concerned it may be a software issue, I re-formatted C:, installed fresh WinXp with updates, and only the software I need. Still the same prob. I use 2 harddrives and changed the one I captured to - same. I now capture to a partition on C: hdd, same thing. I bought another Hauppauge capture card, also PCI - same thing.
Dis-abled all network connections. Nothing else running during capture. I don’t touch the computer at all during capture or encoding. That’s why I have 2 computers. Screen savers diabled. All power options set to never shut down.
Heat sinks and fans clean and clear for both CPU and power supply.
This locking up ONLY occurs during captures, as does the meno-PAUSING issue. Otherwise, my old computer has been rock steady. When I do get a good capture (about ½ the time), there are no issues. Clean and clear. Audio/video in sync, and all that. Different capturing software doesn’t make any difference.
One 2 hour video took 10 tries to get it right. :confused:

When some look at the specs of my computer, you will think it’s too slow. I don’t loose ANY frames during capture, even at this resolution.

Running at factory-set speeds, no over-clocking or modified in any way. Slow and steady.

Ausu A7N8X-E Motherboard
Athlon 1333 Thunderbird CPU
512 DDR ram
Raedon 9550 128mb video
Hauppauge WinTV capture card using Cyberlink PowerDirector3
WinXp

I think I listed all the essentials. I never have a problem during encoding, such as converting these captured videos to DivX, also to the same resolution. I think the prob is hardware, but what? Encoding seems to work the whole thing harder than capturing.

Sorry for the long post.

ANY ideas that I haven’t tried? Besides buying a new computer? If it was that easy, I would have a long time ago. This thing is coming to the grave with me…which at this rate of frustration, may not be THAT far away… :a


#2

Very frustrating. I hate intermittent problems like this.

A few questions. Are you using the latest chipset drivers from Nvidia for your board? Are you using the Nvidia IDE drivers by any chance? If so, stop it right now. The generic IDE drivers in XP work well.

Many Hauppauge cards capture in mpeg only. Is yours one of them or can you capture to avi as well? Which software capture programs have you tried? VirtualDub or VirtualVCR? I vehemently dislike most of the Cyberlink programs, so Powerdirector 3 is an obvious candidate for suspicion on my part.

Tell us the exact model Hauppauge card you are using and the exact capturing configuration you are using—ie resolution, bitrate, codec


#3

I had similiar issues with an Nvidia card last year… never did resolve it, as I replaced my whole PC due to some othe issues…


#4

@ ZackaryMac,
Although you have 512 MBs RAM, are you running other processes during the capture?? Also, are you having a lot of resources being sucked by unnecessary programs running in the background??

System crashing, successful captures having glitches intermittently, kind of sounds like the capturing is putting too much stress on whatever ‘available’ RAM you have left for it.

Just something for you to check.


#5

Hi guys
Thanks for reponding.
I have tried VirtualVCR, though I can’t get the quality as I can with PowerDirector. I don’t know how to properly set up other capture software, it seems, as I select any different compressor, and it either doesn’t work, or there is crappy quality, or it takes up hugh hard drive space. I have tried others like FlyCapsDS, AmCap, etc,all with the same results. It looks like Cyberlink is easier for this dummy, and when it works, I’m quite satisfied with the results.
I did a capture tonight, and it did the choppy thing again. 2½ hours of choppiness. I have nothing else running that I can think of - no networking, no processing of any kind, no screen saver, no music, nothing. As I mentioned before, I usually start PowerDirector after a fresh reboot, go to capture, and set the limit timer, or don’t use it sometimes (doesn’t affect the problem either way), and walk away. Same when I encode, or burn media. I know the processor isn’t too fast, so I don’t ask it to do too much at once.

Will full RAM not cause it to loose frames? Or, asked another way, what would cause it to loose frames? I almost never loose frames. Sometimes, if there is a lot of “snow”, like being on a dead channel, it may skip a few frames, but only then. Even when it’s doing the pausing thing, it doesn’t drop frames.

I will try check on updated drivers, something I didn’t do. I’m doing it right now, actually. :slight_smile:

Sorry for the long posts. You guys must know what it’s like to have a frustrating problem.

Please be patient with me. I’m a self-taught computer novice that’s built a couple of computers, and do my own stuff to them. So I guess that makes me more knowledgable than most average people, but much less knowledgable than you guys.


#6

If you can use Virtual VCR or VirtualDub to capture using a lossless avi codec like HuffyUV, you should be better off than virtually any other solution (except maybe PicVideo Mjpeg codec—but it costs money). The files will be extremely large doing it this way, so you have to have lots of room on the hard drive, but they will be a very good source for you divx conversions. Go to doom9.org and look through their capture guide. It is old, but still relevant for analog sources.

I’ve used an A7N8X Deluxe with 512mb ram to capture video, and did a lot less than you in trying to keep other processes from interfering. I never had problems with that amount of ram. I was using an old Leadtek BT-878 based card.

My only problems came from the crappy Leadtek software, so I eventually went to capturing using the Mainconcept mpeg encoder. That program requires a much faster, more capable computer than VDub + a lossless avi capture codec, and I was still able to capture with no lost frames or stuttering of any kind. My cpu was considerably faster than yours though—a Barton 2600+. Maybe your problem is a combination of the Cyberlink software plus a marginally fast cpu for that particular program. What does Cyberlink recommend on specs?

Have you looked in Task Manager while you are capturing video to see if the capture program is maxing out your cpu? Or if any other processes are interfering?


#7

Well, here’s something interesting.
When I capture, it captures about 1meg/sec.

Power Director, shows an average of about 90% CPU. Yep, spikes at 100.
Power Producer, capturing at the same rate, runs about 77% CPU.
Virtual VCR, running XVid, though I didn’t look at the settings - important, I know - around 50%.
I’m going to download HuffYuv and give it a try. I have about 25G on the partition I usually use.

The freezing problem is much less frequent than the pausing problem.

I’ll get this to work properly yet…thanks to great help! :bow: