Still issue with playing Image

I downloaded and installed the ISO of age of mythology. I ran A-Ray Scanner on it and this came up:
[17:03:12 PM] Signs on CD/DVD indicate SafeDisc 2.70
[17:03:13 PM] SafeDisc 2.70.030 detected -> E:\AOM\AOM.EXE
[17:03:30 PM] SafeDisc 2.70.030 detected -> E:\PATCH\AOM.EXE
[17:03:34 PM] — File(s) Scan Finished [14.46s] –

I ran daemon tools with safedisc checked and it still said "cannot find cd-rom) insert the age of mythology disk. Im not sure what im doing wrong. Maybe daemon tools is the wrong application to use? I dont know.
Help appreciated.

-jp

I guess the previous post I removed didn’t give you a hint…

Downloading copyrighted software is against forum rules, even if you do own the game. If your disc is broken, contact the vendor with proof of purchase (and the original broken discs) and they might provide you with a new disc for only a small administration fee.

Please respect CD Freaks by respecting our rules and keep this forum clean from illegal activities.