Stack Overflow in UGENISO.DLL (in english this time)

vbimport

#1

Hi,
I get the following errormessage when calling NeroBurn(…).

Unhandled Exception in acefw.exe (UGENISO.DLL): 0xC00000FD: Stack Overflow.

Can anybody tell me what the problem might be? All variables have been filled, the device has been opened successfully and an empty CD has been inserted into the drive.

Is ist possible, that one of the callback-functions causes this behavoir? I have created all of them but so far none have been filled with “life”. When debugging my program the callback-function for Progress is called. After that it switches back and fourth between the idle- and abort callback-function and after a couple of times it produces the above mentioned errormessage. :frowning:

Any help would be very much appreciated. :iagree:

Ciao
compiguru

Just for Info the code for calling Neroburn:
int iRes = NeroBurn(m_NeroDeviceHandle, NERO_ISO_AUDIO_CD, pnwcWriteCD, BurnFlags, 0, &m_npProgress);


#2

I have some additional information:

I have written a class, which encapsulates the nero API functions. The goal was to give in House programers an easy to use API. You just link your application with one library and include one File and that’s it. Just to give you an Idea, the class can be used as follows:

CMyBurnClass Burner;

if(Burner.Init())
{
BurnerAddFile(“SomeFile”);
BurnerAddFile(“One more File”);
BurnerAddDirectory(“A directory”);

if(Burner.BurnSelection())
Burner.Close();
}

I have tried this with a programm that was written as a C++ Programm in VisualStudio but without MFC and i get the above mentioned errormessage.

Out of dispair I have created an tiny MFC-Application and tried the same code and what do you know: it work’s! The CD gets burned and everything is fine!

So does anybody have an Idea why the class (nero API) works in an MFC-Application but not in an C++ with windows-sdk application?

Ciao
compiguru


#3

Ok, one more try. :frowning:

I tried my burn program without burning any files and this worked fine (did not produce a stack overflow). I use NeroCreateIsoItem() to create a list of files which I then pass to NeroCreateIsoTrackEx(). When trying to burn one ore more files the program crashes and the last entry in the log states “Phase: Writing to cache” and then “i Caching of files started”.

Anybody have any idea? Please! :confused:

Ciao
compiguru