[split] Problems reading a DVD with the SOHD-16P9S

vbimport

#1

I just ordered myself a liteon DVD-ROM SOHD-16P9S, the read speed doesn’t go half as fast as what my pioneer dvr-109 writer does when i use that to read a disc. I want to avoid using it for that so i get a decent lifespan from the pioneer laser unit etc.
I tried to backup a recently released DVD that I purchased, it was called “Dear Frankie”, I kept getting a read error on some of the IFO files when I tried to back it up using the liteon to read the DVD as usual.
I was just about to give up on the idea of keeping a backup as I really love the DVD, when my bro suggested to read it using the pioneer writer.
It read the DVD straight away, no errors to be seen anywhere. My brother said the firmware mustn’t be updated for it to not read a DVD that we were 100% certain wasn’t down to maybe scratches on the data side of the disc or wear & tear, which I could see anyway as the surface was immaculate - well, it was brand new and hadn’t even been played yet.
Can someone help me with this please, I don’t want to keep having to use my writer to read DVDs that aren’t readable in the liteon DVD-ROM. Before I have to resort to anything like that, I’d rather shell out the cash for a different DVD-ROM that is known to be one of the best that money can buy…However, I don’t have any ideas on where I’d find that quality in a device, surely there is though. But preferably I’d like to keep the liteon if there is some firmware somewhere that’ll fix these minor issues.

Eagerly awaiting all/any feedback at all,
Dave.

BTW - I already tracked down and downloaded the ltnFW application, it’s just the BIN files i need that will upgrade my firmware to the one i need to sort the device out.
Thanks in Advance.