Speed problems with 16/12/40

I have a PIII 1000 with 512 mb ram, IBM 40 gig + IBM 65 gig HD.
Aopen Mobo.

When I ran win98 I could write with no problems at 16*, no underruns, latest firmware, 256 ram.

Now when I run win2000 sp2, 512 ram, latest firmware, I cant write at 16*, else I get around 33 buffer underruns. Someone knows how this is possible, someone can solve it please.

Make sure that DMA is enabled for the drive.

See Device Settings Are Hard to Find in Windows for instructions to enable DMA in Win2000.

Thats the problem, I cant find the

“Advanced settings tab” OS is win2k dutch sp2

only thing that stands there is Intel® 82801BA Ultra ATA controller
and 2* Ultra ATA channel
with all the same 3 tabs.

And If I look on technet, they say something of choose other configuration, like manually, but can’t change that either.

Like Inertia already suggested I’m 99% sure DMA hasn’t been enabled for your drive. I don’t run Windows 2000 but in Windows XP the DMA settings are under the properties of the IDE/ATAPI Controllers. Maybe Inertia or someone else knows the exact location. You can use Nero InfoTool to check if DMA is enabled or disabled for your drive…

Try the instructions at Setting DMA and Display Settings.

[b]To turn on DMA in Windows 2000:

  1. In Control Panel, click the System icon and click the Hardware tab.
  2. Open Device Manager.
  3. Select IDE ATA/ATAPI controllers.
  4. Right-click the Primary IDE Channel icon and select Properties.
  5. Click the Advanced Settings tab, and select the DMA check-box (if it’s not selected already).
  6. Click OK.
    [/b]

The other instructions didn’t mention that you had to go through Properties to get to the Advanced Settings tab.

After installing intel application accelerator I can see now that all my drives Can handle DMA: PIO Mode, DMA SW, MW and UDMA mode. except plextor can’t handle UDMA.

All HD stands on UDMA-5, DVD on UDMA-2 but then the plextor is standing on DMA MW-2

the master 45 disk is DMA enabled, the other slave off

my aopen master is on, my plextor slave off.

Has it something to do with master, slave, or with the cables.

The disks have a yellow IDE cable with much thin wires, the drives have a thick grey IDE cable with less wires.

Drives capable of UDMA 4 & 5 (66 & 100 MB/sec.) require the 80 wire IDE cables. The thicker 40 wire cables can support up to UDMA 2 (33 MB/sec.) but it is better to use the 80 wire cables even for UDMA 2 drives as they provide better shielding from electrical interference and noise.

The 16x Plextor never could connect in UDMA mode. The PleXWriter 16/10/40A Specifications show that the drive either connects in PIO mode 4 or DMA 2. DMA 2 is the same as DMA Multiword 2. It is a true mulithreaded DMA mode, and allows buffer bursts of 16.6 MB/sec.

The maximum throughput of a 16x burner is about 2.4 MB/sec., so DMA MW-2 is entirely adequate to support the performance of this burner.

Try it now and let us know if you can write at 16x without the buffer draining.

According to the vendor it could also be because Burn-Proof is enabled, he says that when I disable it I will be able to burn at 16* lets try that also

The vendor doesn’t have any idea what he is talking about. If you disable BurnProof when you are already having buffer underrun symptoms, all this will do is create an unrecoverable buffer underrun and an automatic coaster. The BurnProof protection on the 16x Plextor does not affect burning speed.

If this vendor has given you any other advice, I would reexamine it to make sure that it is not part of your problem.

From your previous edited post, it appears that you have found that DMA is not enabled for the Plextor drive. If so, as we have already said, that is the problem, not BurnProof. If this same configuration ran fine in Win98 but not Win2000, it seems certain that you are having a DMA allocation problem in Win2000.

Check in your system BIOS and make sure that DMA mode is available for the Plextor, and that it is not set to PIO mode 4. Report the Plextor BIOS setting and what settings are available.

Check the slave setting on the primary channel as well to make sure that it is set to auto-detect or the actual capability of the drive.

It worked.

What I have done:

First I have installed all newest possible drivers of Aopen, and Intell chipset, this changed that my computer found my previous unrecognisable IDE controllers now as Primary and secundary IDE controllers, now I also saw with the nero infotool the setting DMA where before I didn’t saw that setting.

But still I haven’t the advanced button.

Yesterday I disabled burn proof an tried to write at 16*.

This worked so problem solved.
After the weekend I will enable burn-proof again, to see if it’s that, but I think its the reinstallation of latest Intell inf drivers and AOpen drivers that did the trick.

Thx to all you guys for helping me.