Speed problem?

vbimport

#1

Hi, I’m a newbie here, and recently got an LG-4163B.

I’ve done the following:

  1. downloaded A104 firmware
  2. patched with MCSE so that SONY08D1 uses SONY16D1 strategy. (should try to write @ 16x on 8x sony/benq media)

So I run DVD Decryptor, select ‘MAX’ speed, and opened an ISO file that I created with DVD Shrink.

I start burning, DVD Decrypter indicates possible speeds as:

Destination Media Type: DVD-R (Disc ID: SONY08D1) (Speeds: 4x, 8x, 8x, 16x, 16x)

It doesn’t even reach 8x speeds:

Average Write Rate: 3,086 KB/s (2.2x) - Maximum Write Rate: 5,709 KB/s (4.1x)

The drive is master on secondary IDE, and is ultra DMA mode 2. My CPU is an AMD Barton 2500+ o/c to 3200+ levels (2400 Mhz), with 512MB.

Is there a limitation of using DVD Decrypter with LG-4163b?


#2

Interesting. And this read speed is usually much higher using other software?


#3

The only way I could see this happening would be with a small file where the speed never actually gets to reach 8X or something is being reported incorrectly.

I would download the trial of CloneDVD and burn an entire disc and report back the time for burning only. Make sure your DMA setting is still enabled. Is there anything else on this cable? Maybe go to stock A104 and see if that could be the problem?

http://www.elby.de/products/clone_dvd/download.html


#4

I had the same problem (drive would not read or burn above about 10x) with 3 diffrent burners. Make sure that you check your dma settings in the bios and see how the drives are reporting during startup. Windows sometimes lies and falsely reports that it is running in dma when it is not. It must be set to dma in the bios and windows. Also, try running a burst rate test (and or a transfer rate test) in cdspeed to verify that your drive is actually capable of transfering data fast enough to burn at the speeds you want with current settings.
A bad ide cable could be he problem too (but if it is not a dma problem I think I might flash back to oem firmware first, unless you just hapen to have a spare ide cable that you know is good). You are using an 80 conductor ide cable, right?


#5

My LG 4163B DVD writer is the master on the secondary ide channel. I have an LG CD writer/DVD reader combo drive on as the slave.

Disconnecting the slave drive did not improve anything, neither did updating my motherboard drivers.

Could inCD be causing some kind of conflict?

Also, I am using 40 wire cable on the DVD and CD writer drives. Do I really need 80 wire? Win XP reports UDMA mode 2 (which I assume is 33 MB/s throughput which is way more than I need?)


#6

Windows lies. I found out the hard way that with some motherboards (both my nvidia based boards anyway) windows can report that it is running in dma mode when it is actually not. Restart your computer and look through the startup screens (you may have to restart a few times if they go by as fast as mine does) and their should be a line that reports on a hardware level, which mode it is running in. You have to make sure that dma is enabled in your bios reguardless of what windows is reporting.
As far as incd causing a problem, incd can cause lots of problems but I don’t think that it would cause this. What incd and other packet writing programs often do is constantly try to access the drive to see if you have inserted a compatible disk. that can prevent other programs from trying to used the drive and they can try to access during a burn and crash the burn. I have never heard of them causing a slowdown of a burn but I guess it is possible. It wouldn’t be the first thing I would suspect though.
After you have verified that dma in enabled in your bios, download cdspeed (free) and do a burst rate test. That will tell you if the drive is actually capable of transfering data fast enough.
http://www.cdspeed2000.com/
If a 40 wire cable is capable of 33Mb/s, then what hapens if you split that between two drives (it might not have enought for 16x burning). I’m not positive that is the way it works but it could be a possible cause.
Also I think that you need a little extra speed. When I was having dma problems (becaues windows was set for dma and was reporting that it was running dma but the bios wasn’t), the burst rate test was reporting 14Mb/s but when I did a transfer rate test, three diffrent drives could not get past about 10x, which I would have though would only be 10 Mb/s?


#7

Thanks ripit…I swapped my 80 wire ide cable from my hard drives to my DVD and CD drives.

Then it started writing from 6x to 8x!!!

So I thought: okay, now I just have to buy an 80 wire ide cable for my hard drives so they wouldn’t be bogged down with the 40 wire.

As soon as I put in the new 80 wire for my hard drives, the DVD writes went back down to 2.3x - 4x :frowning:

I ran Sisoft sandra benchmark on my primary hard drive and got 15 MB/s.

Then I swapped back in the 40 wire ide cable on my hard drives.

I re-ran Sisoft sandra benchmark on the primary hard drive and got 24 MB/s!

And of course my DVD writing is back to 6x - 8x.

That doesn’t make sense!

  1. Why would my hard drive be faster with 40 wire?

  2. Why would my DVD writer be faster with 40 wire on the primary ide channel?


#8

Yo-

Have you tried swapping drives - making the reader the master and the burner the slave?

May want to try it - I have used this combo for years with great results-

Mike


#9

That is kind of strange. I’m not sure I follow exactlly what you did though. Did you check your dma settings in the bios? Also, some drives seem to prefer a particular setup (as far as which is master or slave and primary or secondary channel). It doesn’t hurt to try changing drives around and see what works.


#10

I went in and experimented with some BIOS settings. Unforunately there is no way for me to specify the UDMA/PIO mode for a particular device. They are all set to AUTO.

There is a setting called DMA enabled/disabled, and either settings ha no effect on my problem.

So then I tried switching around the drives, and isolating them as well, with no success. (actually slower as expected with the DVD writer as a slave on secondary channel)

Then I tried uninstalling IDE drivers and re-installing them with no effect.

So I am now back to 40 wire cable on master and slave hard drives (160gb maxtor and 40gb maxtor) on primary channel, and 80 wire cable on master and slave DVD/Cd drives (LG 4163B and LG 4480B ).

On boot-up, I get a warning that no 80 wire cable on primary channel and hard drives show up as UDMA mode 2; DVD and CD drives show nothing on boot-up.

I don’t know why this works, but my hard drives are actually faster according to Sisoft Sandra (24 MB/s vs. 15 MB/s) and I can burn faster on DVDs (up to 10x vs. 4x)

Perhaps my motherboard (MSI KT3 Ultra 2, KT333 chipset) can’t support UDMA on secondary channel if the UDMA mode is too fast on primary channel???


#11

My only guess would be maybe one of the cables is bad (when they go bad they often work but cause problems one of which can be speed problems or errors). I’m sure it could be something else but I cannot guess what. I wouldn’t think that if it is to fast on the first channel it could limit the second (I have a computer with a cheap piece of shit ecs motherboard and even it doesn’t do that). By the way in the bios, the enable/disable dma is the setting I was talking about. Make sure it is set to enabed on both (you should have seperate settings for primary and secondary channels). I’m not sure what else it could be. Maybe someone else has some ideas?


#12

I just solved my problem.

I was experiencing intermittent re-boots while playing UT 2004, and narrowed it down to a BIOS setting:

Enable CPU HALT Command detection? Enabled

I changed it to disabled, and solved the re-boot problem.

Now with the 80 wire cable I am getting full speed DVD writes!!!

My CPU is a Mobile Athlon Barton XP on a desktop motherboard, so I guess the CPU Halt command on the desktop mobo isn’t quite compatible with the mobile CPU which is meant for a laptop.

And now I get 49 MB/s on my 160GB HD, and 36 MB/s on my 40 GB HD, instead of 24 MB/s.

Weird, huh?


#13

Not so weird, about the cable. They should just trash all the remaining 40 wires.