Speed hacked BenQ 1620 Awesome, Sometimes

vbimport

#1

My Speedhacked 1620 (previously phillips 8631) has been a Phenominally fast DVD Ripper… most of the time. On a couple of occasions I’ve ripped multiple movies in succesion using DVD Shrink. The first couple of movies will rip and or shrink, superfast… (single layer 4-5 min and Dual Layer 13-15 min). Then when I try another one all of a sudden it will only Rip at 2000/KBS for a single layer that normally would rip up to 20,000/KBS. When This happens, I can also use decrypter and it’s the same slow 2,000/KBS.
This happened Yesterday with a 4 GB single layer movie. I took the same movie upstairs to my old dell 1.8 P4 Computer, And using my Aopen 1648/AAP ripped the movie using Decrypter in 5 mins.
Has any one else experienced this odd behavior? Does the BenQ have some sort of Heat sensor that automatically kicks down the read speed after a certain Temp? Any Help would be appreciated.


#2

This has already been reported in the ala42 thread on the riplock software. Ala42 knows about a few reports of this by a few users.


#3

Thanks for the prompt reply Beach.
Is there any resolution Yet? Does anyone Know what causes this?


#4

Yes, it has and it reduces the speed if it is too hot. Does the same problem also occur when the drive is cold ?
I am still waiting on a test result from someone having the same problem, but it seams I will never get the result. Someone else here having this problem with an unscratched disk on a cold drive (just to be shure), other disks ripping at high speed, who can run the test ?


#5

Hey Ala :bow: thanks for the great Firmware. I can’t say whether I’ve had an incident on a cold drive or not. From what I can remember it’s only happened after at least one other rip.

My computer is only 3 weeks old, so I’ve had other things that I’ve been fine tuning. With so many new software and hardware additions, it’s been kind of hard for me to find out what thing is causing what problem. Now that I’ve pretty much got a stable base to work from, I’ll try to do some testing to see if it’s just certain discs or a possible usage issue. I can’t thank you enough for this firmware, I was so pissed when I got my new dell and found out it came with the Phillips 8631. But after the crossflash to 1620 and your MCSE patch, this thing is unbelievable.

I’m running an Dell 8400 P4 3.0GHz, 1024 Meg DDR2 Sdram, 160GB SATA HD windows XP, Nero 6.6.0.8, DVD shrink 3.2 and just upgraded to decrypter 3.5.4. I have a Pioneer dvr-107 and the 1620 on my primary IDE Channel, with the 1620 as the slave. They are both running in ultra DMA 2.


#6

This is interesting. I have two DVD recorders on my system (it’s an NVidia P3200 nForce2 motherboard), a BenQ 1620 and a NEC 3500 drive. I’ve run into a problem when I try to do a disc copy from one DVD to the other when Nero is configured for on-the-fly mode operation (not recommended, by the way).

Unfortunately, both DVD recorders are on the same IDE channel, and I have found that the copying speed will peak to nearly 8X and then drop off very quickly to 2X - 3X. Frequently, this low speed will persist into the verify stage, and occasionally a reboot is necessary to correct the problem.

I’ve always assumed that it was caused by some sort of an IDE bus conflict, with Windows recognizing an IDE problem and deliberately slowing the modes down from Ultra DMA mode 2 to something slower (without reporting it in the system configuration) in an attempt to resolve the problem.

But I’ve never considered that it might have been a heat related issue…

I have yet to see this slowdown by ripping a pressed disc, but then again, I don’t rip a lot of movies.

Here’s a related quote from an article found at this link:
http://users.bigpond.net.au/ninjaduck/itserviceduck/udma_fix/

A maddeningly understated problem arises with how Windoze locks down what it thinks is the best transfer mode for each of your IDE devices. After the initial hardware detection, XP keeps a running tally of the number of times a drive fails access attempts. When this number reaches six, it reduces the compatibility mode and tries again. At first XP will try downgrading within the same transfer method, eg: from UDMA Mode 4 to UDMA Mode 3, but when these sublevels run out it will assume DMA is no longer available and permanently fail back to PIO Mode


#7

Hi ala. I’ve yet to encounter any speed reduction during ripping, but that was with a cold drive. However, tonight, I will try ripping 5 discs with Decrypter in a row and see what happens.

Cheers,

Jie


#8

Well I did some major testing tonight, and I don’t think my problem is heat related.

The following is Using my (phillips 8631)BenQ 1620 ALA MCSE Hacked B7U9 and DVD Decrypter 3.5.4 (Microsoft SPTI) on my Dell 8400 P4 3.0GHz, 1024 Meg DDR2, 160 GB SATA HD, The BenQ is the Slave on my Primary IDE, Ultra DMA2.

  [B]ALL THE FOLLOWING DVDS ARE NTSC REGION 1 AND IN PRESTINE CONDITION[/B]

(1) GANGS OF NEW YORK DISC 2 Dual Layer pressed 7 GB Ripped in 9:12 MIN

1 minute in between

(2) Blade Runner 16x9 single layer pressed 4.35 GB started to rip at 1.8x let run for a minute no improvement… canceled rip. ejected. rebooted

3 Min in between

(3) Blade Runner 16x9 single layer pressed 4.35 GB started to rip at 1.8x again let run for a minute no improvement…canceled rip. ejected.

1 Min in between

(4) Strawberry Shortcake meet strawberry single layer pressed 3.2 GB ripped in 3:54 Min

1 Min in between

(5) Blade Runner 16X9 single layer pressed started at 1.8x again no improvement canceled after a minute.

1 Min in Between

(6) Gangs of New York Disc 1 dual layer pressed 8.3 GB ripped in 10:02

1 Min in between

(7) Spirit dual layer pressed 7.5 GB ripped in 9:33 MIN

1 Min in Between

(8) Blade Runner 4x3 (opposite side of 16x9 Disc) single layer pressed started at 1.8x no improvement after a minute…canceled

1 Min in between

(9) Risky Business 16x9 single layer pressed 4.5GB ripped in 4:55Min

1 Min in between

(10) Rolie Polie Olie Great defenders dual layer pressed 6.7GB ripped in 7:42Min

1 Min in between

(11) Disclosure 16x9 single layer pressed 4.2 GB ripped in 4:46Min

1 Min in between

(12) Blade Runner 16x9 single layer pressed started at 1.8x again let it run 1 min then canceled.

1 min in between

(13) Edward Scissorhands DVD-R 4.4GB ripped in 5:00 MIN

1 min in between

Switched to using DVD SHRINK to Rip the Movies

(14) Blade Runner 16X9 single layer pressed started at 2,000/kbs and never really moved up from there…canceled after aprox 3 min.

1 min in between

(15) Heat dual layer pressed 7.1GB ripped and shrunk in 10:18

1 min in between

(16) Risky Business 16x9 single layer pressed 4.5GB ripped in 5min

[B] END OF TEST[/B]

So the second disc I tried to rip (BLADE RUNNER) is the only disc I had problems with. It’s strange because it is in excellent physical condition. I also think it’s funny that it didn’t matter which side of the disc I used the 16x9 side or 4x3 side or which program I used decrypter or shrink it still was slow.
Given the amount of discs I ripped and the short time in between each one, I really don’t think it’s a heat issue with me. I might be crazy but as I recall the last time the slowdown happened it was the second disc that slowed. And I’m almost positive the slow disc has never been a Dual Layer pressed or even a DVD-R, It has always been a single layer pressed. I have to mention that the same BLADE RUNNER disc burned at 12X on my old computer using an Aopen 1648/AAP, right after all this testing.

So once again ALA thanks for the Great Hack, this is just a small nuisance in the grand scheme of things. I still can’t get over how fast this thing rips. Its fantastic.


#9

But how exactly does it reduce the speed ? I mean, does it reduce all the curve like drive is still not patched by your great tool MCSE or does it reduce at sometimes like on bad media ? I’m asking because after patching my drive (firmware is B7T9) with MCSE some dvd+rw-4x disks are read not for the end at 16x, and I wonder, if it is besause of media/drive is not suit for such a high reading speed of rw-media or my drive is just overheated ?


#10

I tried one more time after all was said and done to rip Blade runner. To no avail (see attachment). And just to make sure It wasn’t a hardware issue I also ripped Risky Business again (see attachment) it worked great for risky but so slooow again for blade runner.

decrypter risky business.txt (1.57 KB)

decrypter Blade runner.txt (1.8 KB)


#11

Damnit :o I just realized I put BenQ 1648 in the header :o I apologize I meant 1620… Is there any way to edit this? I feel like such a tool… I just got an Aopen 1648 for my other computer, I must have had that in my head… :confused: sorry MODS is there any way you can change this to BenQ 1620 for future searches


#12

I can not tell you exactly how the speed is reduced, I just saw some debug messages in the firmware.
RW disks have a very low reflectivity, so the problems you saw are probably just caused by the high read speed. Nothing to worry about.


#13

How fast can you rip your double sided single layer DVD with the original firmware ?


#14

I can Honestly say I don’t Know. I never tried with the stock firmware. I guess I probably should’ve created a baseline but the speed hack was to enticing…I just couldn’t resist. Im sure the stocker would probably be about the same as what I got with the Bum Blade Runner rip. If you really think it’ll help I guess I could flash back and see what I get.

But from what I gathered tonight, it sure seems like its either a certain type of disc or even a stranger possibility the 2nd disc burned in succession :confused:.
It just seems strange that both dvd decrpter and shrink would both be so slow on that blade runner disc after the first slow down. I’m going to turn of the computer overnight and try Blade runner again tommorow and see if I get the same results.

Either way I’ll still take 10 good rips for every 1 bad rip any day, if their all as fast as with the MCSE hack.


#15

Thank you for confirming my own guess !
ps. Sorry for my english, I’m russian.


#16

I think that would be a very interesting and potentially useful piece of information!


#17

I’ll give it a shot tonight


#18

Well another update. I left the computer off all night restarted fresh this afternoon. I still have B7U9 with MCSE patch installed.

I got some new movies today so I figured I try em out. I just used DVD Shrink 3.2 to back up 4 movies in a row with no problems. I made sure the second disc was a single layer pressed and it ripped just as fast as it should’ve with the MCSE speed. After I tried those I figured I’d give BLADE RUNNER another try… No luck still 2000/KBS. So It’s got to just be certain discs that this patch will not read fast. This Blade Runner Director’s cut is a very early DVD from late 90’s the kind with single layers on both sides of the disc. But it can’t be just that type of disc because both Risky Business and Disclosure are the same type and ripped fine.

The only strange thing I noticed was when Blade runner was inserted and I tried to open up the dis in DVD Shrink there was no volume label listed under my D: drive. Normally you see something like D: DVD_Volume or D: Risky_Business but when Blade Runner is loaded all you get is D:
When you click on it it does recognize there is a disc there and will start to open it. So I don’t know if The lack of a label would have anything to do with the problem. But I definately don’t think my problem is heat related.


#19

I flashed back to stock B7T9, and there was no difference with the slow Blade Runner Rip…still right around (1.8x).
I also tried a Known fast SL movie (risky Business) with the stock B7T9 firmware and it was super fast. Ripped in 4:54 MIN at a max of 16.1x… man I never realized the stock firmware was that fast for a single layer movie.

Well I can only conclude that the BenQ1620 just doesn’t like this version of (BLADE RUNNER). Any one else have this in there collection?


#20

Well yet another update in this ongoing battle of the slow rips. I did some flashing and reflashing tonight now I’m back to the original B7U9 MCSE patched.

I started to run another sequence of rip tests tonight. The very first disc I tried ( Rolie Polie Olie Great Defenders of Fun ) a 6.35GB Dual Layer pressed disc is now exhibiting the same problems as Blade Runner. You put it in the drive and you never even hear the drive ramp up speed like with other discs. Now what’s very puzzling about this is… this same disc worked in my last nights testing without a hitch… see #(10) in last nights rip tests. And as of right know I’m on my 4th straight pressed disc rip, without a speed problem since the first Rolie Polie Olie disc. Blade Runner still won’t rip fast though.

So I really have no clue whats going on with this thing. I’m just glad It still works for the Vast Majority of my discs.