SP1604N+USB2.0 Encl produces unusual combo - can it get better?

vbimport

#1

I got a samsung 160GB SP1604N and paired it up at first with a cypress At2 bridge, and I got USB 1.1 only :S … Or USB2.0 and it somehow disconnects itself. The AT2 is happy with my WD 200GB though. So I hook it up with my other Prolific PL-2507 chipset and i get uSB2 - but the performance looks like the graph below. Is it possible to get better performance (because this drive nears 50-60MB/s on the IDE internal) through USB 2 (and if so, which chipset would you recommend?)


#2

i wouldnt say its an “unusual combo” its a fact that usb/firewire are much slower then hard drives in the future there will be firewire 800 external enclosures then it will be preety equal , that transfer rate is normal for an hd connected with usb2

youll get better performance with firewire , but not that much


#3

hmm - it’s unusual since this drive refuses to work at all with Cypress AT2 (got 2 different revisions of them and both revert to USB 1.1 for some reason with 1MB/s burst rate :()


#4

Are you sure it’s the USB<->IDE controller that’s responsible for the problems? On my former mainboard, a MSI K8T Neo-R, I had the exact same problem (with a different controller though). I solved the problem by trying all my USB ports till I found one that did work alright. Don’t ask my why, but it worked. The other USB ports worked just fine, but not with my external enclosure. And yes… they were connected to the very same USB controller on the mainboard!

I know it sounds silly, but it might be worth a try!


#5

Well, that looks what you can expect out of USB2.
This is from my old Maxtor 40Gb drive (CPU Load is a bit high because I did a bunch of things during benchmark).
//Danne



#6

Hmm … good idea, but this mobo has one root hub however I will try it.

EDIT: I did however try it, but I don’t kno, maybe it affect VIA motherboards (since all 3 of my computers have VIA USB) -all ports exhibited this apparrent problem, but checking the USB info, it says USB2.0 -> maybe it’s between the CHIPSET and Drive?

EDIT: seems similar - tops out at no higher than 33MB/s