SOSW-852S Issues

vbimport

#1

I hit up ebay for a 8x dual layer burner for my laptop to replace the old 4x single layer and wound up buying a Sony DW-R56A. It wouldn’t burn to my ritek 8x +r’s at anything more than 4x so I started reading and going off this:
** INFO : Drive = SONY DVD+RW DW-R56A [FW QDS1]
** INFO : Write Capabilities = DVD+R DVD+R-DL DVD+RW
** INFO : Disc = [DVD+R:RITEK-R03-002]
I ran MCSE to open up 8x for that media type since thats what they’re supposed to be rated for. Still crappy performance. So I read some more and see that its a rebranded liteon, so I grabbed LITE-ON SOSW-852S version PST3 patched it and hit it with MCSE. Still same thing.

My laptop has a slow 4200rpm drive/1.4pentiumM and it seems to struggle a bit. When burning the buffer in nero drops to 15-20% and spikes back up to 100 the whole time, but it never bottoms out and it never records that it had to use underrun protection. I went back to the sony firmware and tried one more, 2657MB burned at 6x on 8x media took 24:47 which is what like 1715KB/s. Wow, crappy.

Also I noticed on the old burner the ritek dvds would be playable on all dvd players and data dvds readable in my desktop with an old dvdrom. With the new drive, and same media, my discs are unplayable in older dvd players and in my desktop dvdrom.

I’ve tried other media and all the problems are unchanged. Heres some info from the new firmware and a maxell 8x dvd+r

** INFO : An Empty Writable Disc Is Recommended For Accurate Results
** INFO : Drive = Slimtype DVDRW SOSW-852S [FW PST3]
** INFO : Write Capabilities = DVD+R DVD+R-DL DVD+RW DVD-R DVD-RW
** INFO : Disc = [DVD+R:MAXELL-002-000]
** INFO : Write Speeds (Supported By This Drive On This Disc) Listed Below

** INFO : GET PERFORMANCE Write Speed Descriptor(s)
Descriptor #1 = 8310 KBPS ( 6.00x) - [CLV/Non-Pure CAV]
Descriptor #2 = 5540 KBPS ( 4.00x) - [CLV/Non-Pure CAV]
Descriptor #3 = 3324 KBPS ( 2.40x) - [CLV/Non-Pure CAV]

** INFO : MODE SENSE Write Speed Descriptor(s) [Legacy Command]
Descriptor #1 = 8310 KBPS ( 6.00x) - [CLV/Non-Pure CAV]
Descriptor #2 = 0 KBPS ( 0.00x) - [CLV/Non-Pure CAV] - [Invalid Entry]
Descriptor #3 = 0 KBPS ( 0.00x) - [CLV/Non-Pure CAV] - [Invalid Entry]
** WARNING : Drive May Have Returned Incorrect Descriptors

0010 : 00 00 03 4d 41 58 45 4c 4c 00 00 30 30 32 00 38 …MAXELL…002.8

Any suggestions to get me burning again at a decent speed, or with more compatible discs would be appreciated because I’m stumped on whats wrong.


#2

For some reason, Nero never reports a buffer underrun even when it happens. The burn time that you’re getting for a 4200 RPM laptop hard drive looks about right, actually. The way that Nero (stupidly, IMHO) handles buffer underruns is to halt the burn and let the buffer fill back up to 100% before burning again, which produces fewer underruns, but makes each underrun take a LONG time, and the effects do not cancel out (because now part of the buffer-filling time is spent idle), so it is very common for a burn to take longer at a higher selected speed in Nero because of the underruns that it’ll get; the one time I tried to burn at 8x on my 4200 RPM laptop HDD, Nero took twice as long as it did at 4x. If you don’t believe me, run a disc creation test in Nero CD-DVD Speed, which will take the hard drive speed out of the equation… Not all software are as bad at handling underruns as Nero; for example, DVD Decrypter just keeps going at whatever speed it can, which is a much more sensible way of handling underruns.

As for the disc playing back, can you use KProbe to get a scan of a burned disc? See my sig for info on creating and attaching a disc quality scan.


#3

Interesting I would have swore that at some point I used to see nero note in the log that is used burnproof or something, but I wasn’t sure. I didnt expect the drive to be so throughput limited, perhaps time to consider a big cache 7200rpm heh. Anyway I ran the nero program and got 1.66x average…

Here’s a Kprobe result from a dvd I burned on this burner at probably 4x I’d guess.




#4

Heres a dvd I burned with the old 4x drive



#5

And finally a retail dvd, star wars episode 2



#6

Hrm… 1.66x? You shouldn’t be getting a speed that low using CD-DVD Speed because it isn’t limited by the HDD. Is DMA turned on? Can you get CD-DVD Speed to give you a burst rate for the drive?


#7

Burst 3MB/s or 2796KB/s if you prefer

I went to device manager (xp btw) and then primary ide channel advanced tab :
device 0 device type auto detect, dma if available, current mode UDMA 5
device1 device type auto detect, dma is available, current mode not applicable

secondary channel
device 0 (i assume this would be it) device type auto detection (greyed out), transfer mode dma if available, current transfermode not applicable
device1 - just like device 1 on first channel

So it looks like perhaps we’re on the right track, is there a better way to look/force dma settings in xp?


#8

Does this help?
http://www.cdrlabs.com/phpBB/viewtopic.php?t=6645

A healty burst rate should be around 20 MB/s, usually more.


#9

Indeed, the regedit seemed to give me udma2, 23MB/s thanks!


#10

Mmm did a 4x burn to a maxell in 15 minutes buffer never went below 97%, it was sweet.

Does this look like a decent kprobe test? It seems high at one point. I’ll do another ritek soon.



#11

Wow here’s 8x ritek at 4x… I was always under the impression that ritek was quality media, more than maxell, does this show otherwise or is there something else I need to do?

Thanks again!



#12

You should set your scanning speed to 4x… that should get rid of the spiking and produce more accurate results.

Ritek is okay media. They’re not considered to be bad media (unlike Princo and the whole bunch of generics out there), but they’re certainly not what one would consider good, either. Ritek’s only high-quality products are its Ricoh discs (RICOHJPNR01, R02, R03…), which are pretty good (and used by lots of brands, such as Sony, Fuji, etc.), but that’s probably because they use Ricoh’s technology and dyes for those products and not their own. They sometimes sell Ricoh media under their own brand and name, and it’s just luck whether or not a Ritek spindle contains Ricoh media or Ritek media. Ritek’s double layer media is the cheapest out there, so it’s one of the most popular kinds, but it’s also one of the crappiest.

Maxell is generally good.


#13

Heh man that sucks…I ordered a 50 pack from newegg that said they were hub printable, they weren’t and the quality isn’t as good as the maxell’s I got from walmart :smiley: Now to find some good quality hub printable 8x or greater single layer +r’s.

Hmmm I didnt see the option in kprobe so I set 4x in nero drivespeed and am trying kprobe again. For what its worth the maxell disc with the decent looking kprobe result still won’t play in the old toshiba player that the old burner managed to write discs for, probably still a quality issue?

Thanks again

Heres 1 more burn and 1 more probe locked at 4x off a maxell



#14

Hello people,
My SOS-852sis driving me nuts. It wouldn’t even read the disc it burned. It doesn’t read DVD-RWs and certain CDs. I was trying to copy a DVD. The reading process seems to be interrupted every now and then; the data transfer rate drops to almost 0 for a few seconds during which time I hear the disc spinning fast and the resumes reading. If I can’t fix this I will have to send it for service which is a pain.

Thanks in advance for suggestions.
Dev