Sony NEC BC-5500A Firmware

vbimport

#1

After reading dozens of posts on the issue of the firmware update for these units, I’m still at a loss to what to do.

I picked up a unit and of course soon as I went to play a new Blu-Ray it states that I need a firmware update for the security.

Well, I found the update at Sony. Unfortunately, it only works if you have the drive in a Sony Vaio.

Is there anyway that someone could reverse engineer the update and remove the Vaio requirement or extract the firmware update for use with Binflash?

Here is the link to the first one… for firmware 1.7f

http://esupport.sony.com/US/perl/swu-download.pl?mdl=VGNAR830E&upd_id=5858

I do have a download with the same issue (vaio) that does 1.7e…

Greatly appreciate any help.


#2

What is your current firmware?


#3

Not sure which number is the actual firmware.

Binflash says…

Optiarc DB ROM BC-5500A 1.79

GUI version v1.63
Drive interface v1.52
NEC interface v1.63
NEC internal v1.63


#4

[QUOTE=Greyfox_mt;2720924]
Optiarc DB ROM BC-5500A 1.79
[/QUOTE]

OK, that sounds like a Sony OEM firmware, so the 1.7F should hopefully work. Try this 1.7F flasher extracted from the downloaded Sony wrapper package: http://www40.zippyshare.com/v/62114864/file.html


#5

Thank you. I’ll take a look at that.

Something very interesting… I ditched my old PowerDVD software and tried to use a copy trial version of PowerDVD 13. Wouldn’t work stating I didn’t have hardware acceleration.

So I downloaded a free trial of Easy DVD Player. Movie played fine at that point.

PS… Firmware upgrade worked. Thanks.


#6

Can you please post another link with this 1.7f flasher?
Thank you and have a nice day!


#7

[QUOTE=cvs;2720943]OK, that sounds like a Sony OEM firmware, so the 1.7F should hopefully work. Try this 1.7F flasher extracted from the downloaded Sony wrapper package: http://www40.zippyshare.com/v/62114864/file.html[/QUOTE]

Hi. I have the same problem and I think you can help me.
My drive is this one: [Optiarc BD ROM BC-5500A 1.B4]

Binflash says this:

GUI version v1.63
Drive interface v1.52
NEC interface v1.63
NEC internal v1.63

My laptop is acer aspire 6920G
Can you help me by posting this link again? I want to try flashing this 1.7F
Thank you!


#8

[QUOTE=paralyser;2748379]Hi. I have the same problem and I think you can help me.
My drive is this one: [Optiarc BD ROM BC-5500A 1.B4]

Can you help me by posting this link again? I want to try flashing this 1.7F
Thank you![/QUOTE]

I can post the link but it won’t help you at all. Unfortunately in your case you’re out of luck. The 1.7F flasher will not allow you to flash a 1.B4 drive, and unfortunately there are no other suitable firmware updates which would work for your drive either.

Some of these OEM drives do come with a 1.B6 firmware on board, which would work for your drive, but unfortunately Binflash can’t dump the firmware from these drives and without a valid 1.B6 dump or a normal 1.B6 firmware update (*.exe program) which isn’t available either, you’re basically completely out of luck.

Unfortunately OEM crossflashing such as 1.B4 to 1.7F is not currently possible for these drives. The firmware encryption these drives use, proved to be a very tough nut to crack, and without figuring that out it is just not possible to fully support these drives (such as full support for dumping, flashing and OEM crossflashing).


#9

I understand. Thank you for explanation! Have a nice day!


#10

CVS, would you mind reuploading the file please?

I have 5500S that was taken out of dead Sony laptop with 1.75 firmware, then updated to 1.78 (somebody extracted it). Now I see this is a much newer firmware. Obviously I don’t have the laptop anymore to install the official f/w.
Tried extracting myself, and looking under Temp with no results. Thanks


#11

[QUOTE=m00nman;2763097]CVS, would you mind reuploading the file please?

I have 5500S that was taken out of dead Sony laptop with 1.75 firmware, then updated to 1.78 (somebody extracted it). Now I see this is a much newer firmware. Obviously I don’t have the laptop anymore to install the official f/w.
Tried extracting myself, and looking under Temp with no results. Thanks[/QUOTE]

Ah looks like 1.7f is for PATA model, while 1.78 is the latest for SATA.


#12

[QUOTE=m00nman;2763099]Ah looks like 1.7f is for PATA model, while 1.78 is the latest for SATA.[/QUOTE]

That’s correct, 1.78 is the latest available firmware for your drive.


#13

i dont understand it, is now a 5500A with 1.7F Firmware better than the OEM 5500 1.b4?

Which are the differences, i have the one with 1.b4 and its works fine, now i think about to buy one which is updateable or you think i dont need it and my Drive is OK, i dont know what i have to do?

Can anybody explain it me? Sry for my bad englisch

Thanks You

regards