SONY/NEC 18x Optiarc AD-5170A Problems!

Hi,

Bought the above drive a few days ago from DABs. Basically had problems from the start. The drive seemed to be very read sensitive. It just would not read any disk, unless I gave them a good wipe first (My other DVD drives, are less fussy).

Now, the main problem I have, is after I copy a DVD, the copy plays fine in a DVD player (Movie), It plays/reads fine in other DVD PC drives (Sony, Emprex, etc), but, and this is the strange part, will not read on the Optiarc (which has just done the burn!).

The Optiarc cannot read it’s own burns, but other drives can. This is a bit like not being able to read your own hand writing, but everyone else can!

What’s going on? If the drive was really faulty, would other drives still be able to read it’s copies/burns?

I’m thinking of buying another one of these from DABs, just to compare them, and then send the original one back if the new one works fine (e.g. reads it’s own burns).

Other info:
Firmware 1.11 / Media: Ritek G05 / Burning software: NERO XP / NERO LINUX / K3B LINUX.
(XP SP2 / Fedora Linux (2.6.18 Kernel) )

Thanks,
Nick.

Ritek G05 is crappy media! It has major deterioration issues!
Try Verbatim, Taiyo Yuden or Sony.

Thanks for the media tip. Lots of people used to recommend Ritek, which is why I use them.

Looks like my drive is faully though, this morning drive will not read anything. I have tried about 5 original movie DVD’s. The drive clicks about for a few moments then nothing. Put the disks in another drive, they start up no problem. Looks like this drive is going back to DABS. Not a good start for my first Optiarc drive!

Thank again.

They used to recommend Ritek long ago, before the G05 started to show problems. :wink:

Well, I had the same problem as you. First the drive couldn’t read it’s own just-burned disks. Few days later the drive didn’t burn anything anymore. What I did is:

  • Put another IDE cable on it. (Ultra DMA-5)
  • Got 2 hard drives on the first IDE-cable and the optiarc 5170 on the other IDE cable with the jumper set as master

I hope this will be the solution for your problem too :slight_smile:

From working with these drives I have found that in 100% of them they have problems burning DVD’s at the lower firmware revisions. I suggest updating the firmware before trying to return the drive. Has worked for me on at least 50 of these drives if not more.

Hello,
I have the same problem with external AD-5170 :sad: . Probably it’s not an IDE issue, becouse I have to connect it to the Laptop via USB2 cabel.
Can you explane me,please, how can I upgrade the firmware version (never did this before)? Where can I download the new version and how to install?

Thank you in advance