SONY/NEC 18x Optiarc AD-5170A does not read blank DVD-R

Hi all,

I was sent the SONY/NEC 18x Optiarc AD-5170A drive as a replacement for my faulty LiteOn writer, since I was still under guarantee.

They provide a service where they send you the part, you replace it yourself and then send the old one back.

I made the switch comfortably.

However, a week on I have come to make my first burn and find my DVD-R does not get read by the drive, i.e. Windows does not prompt me to say a blank DVD has been inserted, the My Computer drive remains as if their is no disc inserted and multiple burner software such as DVD Decrypter state that no media is inserted.

I have tried Verbatim and TDK and no luck.

If I put a CD-R in there, it is read fine and can be burned to without a problem.

A shop bought game CD worked fine, but not a shop bought Audio CD.
But not DVDs I burned in the past. And I tried a DVD movie which wasn’t read either.

Any ideas.

Its set as slave and shares an IDE cable with the reader.
The hard drives are SATA ones.

Thanks in advance.

P.S. The issue with my old drive from the day I got the PC was it would read discs but simply not write (would get a burn process failure).

It detoriated to the point where it would not read disks (though CDs were OK).

No drive can READ a BLANK media, because there is nothing on it…

Install and use a proper burning app, then use the media what they are made for, burning.