SONY DW Q58A - wont read..please help

My girlfriends DELL Inspiron 1300 wont read any discs at all…
after re-installing it in device manager the drive was still the same,
nor would it boot up an XP cd at POST when i first turned
on the machine… this led me to believe that the firmware
could be corrupt?, I backed it up using EEPROM and installed another
firmware which didnt work (this time the drive light flashes orange)
I tried “UDS2WIN.EXE” then “Sony Q58A.USY3Stock” and it still didn’t
work (and the light still flashes orange), when I tried to use
the EEPROM to restore the original “UDS1” it wont work, now the drive
has “UYS3” firmware… also when I try to install the UDS2 it says its
only for the “SONY-+RW DW-Q58A” drive and it detects “SONY RW DW-Q58A UYS3”

Iam obviously new to flashing drives and im certain thats what the main
problem is…can anyone PLEASE help… :bow: :bow:

thanks in advance

paul

Sounds like it’s dead if you cannot boot XP from it.

its defo not broke / dead , it trys to read and DELL DIAGS say that the device checks OK but fails read or write tests and windows reports that device is working properley… this has to be firmware, but now im stuck on UYS3 and cant revert to its original UDS1, (at least the lights were green then, now they are orange)…

Sound like you put Lite-On firmware on it if the light is orange. Sony firmware has green light. So you need to cross flash it. Read through the Read First posts here or use Search button.

Iam a bit confused as the site I was on said that SONY had been rebranded to LiteOn,
here is a link to the page where I downloaded and used the firmware updates (I used EEPROM to back up the original firmware but it says its restored but actually hasnt)
http://forum.rpc1.org/dl_firmware.php?download_id=2113
I cant find the read first posts and here is a page thats says you can use liteon software/firmware on sony drives (at the bottom for SONY DW Q58A + Q60A)
http://club.cdfreaks.com/showthread.php?t=140594&highlight=crossflashing