Sony DW-Q58A 8X Slim DVD+/-RW Drive fix

I ran into many issues trying to get my Dell Inspiron E1705 to burn DL DVDs with the Sony DW-Q58A 8X Slim DVD+/-RW Drive. I made a few coasters but found a cure.
To make a long story short do the following to get just about any media brand burnt and working. I have firmware UYS3 and use Nero 7.2.0.3b along with either/and DVD Shrink 3.2, DVD Decrypter 3.5.4.0, DVDFab Platiunum 2.9.8.1 and VOBlanker 1.6.0.3.
I used RiDATA DVD-R DL 4x and Matrix DVD+R DL 2.4x certified. Both worked fine.

You need to run MSCONFIG to resolve this issue.

Click the Start button, and then click Run.
The Run window appears.

Type msconfig in the Open: field, and then click the OK button.

The System Configuration Utility window appears.
Click the radio button for Selective Startup.
Click to deselect Process SYSTEM.INI File.
Click to deselect Process WIN.INI File.
Click to deselect Load Startup Items.
Click the Services tab.

Click to select Hide All Microsoft Services in the Services Tab.
Then go to Startup tab and Click the Disable All button.
Click the OK button.
A restart request window appears.

Click the Yes button to restart the computer.

I used [B]RiDATA DVD-R DL 4x and Matrix DVD+R DL 2.4x[/B] certified. Both worked fine.

I’d say that both is crap or not recommended media…