Sony DW-Q520A Firmware woes

vbimport

#1

morning ,
I recently replaced my dvd-rom drive with a sparkly new DW-Q520A DVD-RW on my tosh laptop.
Since the drive has been installed, the laptop will display a IDE #1 Error message on restart.
Doing some investigation on this forum i’ve worked out its a master/slave problem on the drive firmware (HYS2)
Have tried
http://codeguys.rpc1.org/utilities/E2MS_WIN_DW-Q520A.rar but problem persists
http://codeguys.rpc1.org/utilities/slim_master-slave.rar says the drive isbt this type.

Any more suggestions?

Mark

(PS EEPROM Utility 3.8.3 does not recognise the HYS2.BIN file format)


#2

Hello, download this PDF file
http://www.tks-computer.com/files/Slimline-FAQ.PDF
go to page 15, there is a picture as to where you must modify your DVD burner.
I have the same Sony DVD burner , and my Toshiba also showed IDE#1 error. It is not possible to flash the burner to fool the Toshiba into accepting it, i tried all the tools you mentioned.
You have to open the burner and connect pin 47 (CSEL) to ground (pin 45) Of course you can also dismantle the laptop and modify there if you want to keep the burner untouched for warranty reasons. Mail me if you have any more questions.
http://www.tks-computer.com/files/Slimline-FAQ.PDF