Sony dw-q30a firmware update/burning problem

vbimport

#1

I just purchased this drive and have two problems.

So far every data DVD-R I’ve tried to burn has ended up a coaster. It seems to burn fine, buring programs say it’s a success, and looking at the disk something has definitely been burned. But when I try to open the dvd, there doesn’t seem to be anything on it. My dvd drive says there’s no disc inserted and the q30a sometimes recognizes there’s 2.4 gig worth of data on there, but no files show up in windows explorer, and sometimes causes it to hang.

I’ve tried several burning programmes, and the lowest possible writing speed.

Secondly, while looking at these forums for help, I saw there was new firmware out, so I downloaded the YYS6, and the liteon YS0W firmware. When I try to update to either, the update program comes up with the Error message ‘unable to update firmware, please contact your vendor’.

Any help would be greatly appreciated.


#2

I had this exact same problem. I spent an hour trying different combinations to see if anything would work and it finally did.

!!!THIS METHOD WORKED FOR ME!!!
1.With computer off, pull the IDE cable out of the back of dvd drive (but keep the power in)
2.Start up computer allowing bios to run as normal
3.When windows(xp) starts loading, put the IDE cable back into the drive
4.When everything has loaded, the computer will not see the drive (in “my computer”). So go to device manager and perform a search for new devices, it will now see it.
5. Just run the flash program (.exe)

Thats what worked, and it works every time for me.


#3

Was the Liteon firmware flashfixed?


#4

:iagree:

I don’t know if there is flashfixed firmware for that drive (to allow you to flash your Sony to a LiteOn)…a look on the CodeGuys site might help. :slight_smile:

Bear in mind you’ll void your warranty if you use any patched firmware. :wink:


#5

Sounds a little risky, plugging in the IDE cable on a live system.


#6

Put it this way, I wouldn’t risk it. :wink:

But each to his/her own, I suppose?


#7

Well, YS0W is from SHW-1635S.
My SHW-16H5S reports that it is a SONY DW-Q31A, so I think it should be correct. :slight_smile:
But have you used flashfixed firmware?