Sony DW-D23A Troubles

vbimport

#1

Hey, I just gotta Sony DW-D23A and I’m having all sorts of problems with it.
This is the first DVD burner I’ve bought so I’m not entirely familiar with them… but anyway, after installing it it shows up fine and everything, but when I put a DVD in it the computer just locks up, which can be solved by removing the DVD… and I tried to burn a DVD and a similar thing happened, although the DVD wouldn’t come out and there would be no progress showing on the burn.

I was looking around for firmware for it and tried a couple things for LiteOn drives as I saw that a lot of people said it was a 1653S or 1673, but it wasn’t working when I tried those so… I was just wondering if someone could help me out with this? Never installed firmware before either so… not entirely sure about that :smiley:
Basically if someone could just clarify what drive it is, which firmware to install and how to do this that would be a great help…

One of the options I was considering, though, was just to take it back and get a Pioneer DVR-109 since I’ve seen a lot of people say those are a lot better.

Also, I want to point out that when I bought this drive it said DWU-23A, but checking it in hardware says it’s a DW-D23A…so that’s a little confusing… plus, I looked at a bunch of 1653s drives and mines looks different, it doesn’t have the volume control on there, just an LED and the CD-Eject button.


#2

what firmware version is on the drive now?

you can check this with nero infotool: http://www.cdspeed2000.com/files/NeroInfoTool_301.zip


#3

It’s CYS1 according to that Nero info tool.


#4

so your drive is a 1653S. you can update with this firmware: http://codeguys.rpc1.org/firmwares/1653S.CS0M.patched-cf-ledfix.rar

just run the .exe. if you have bundled software, you can apply the file with “sonyid”. your drive will remain a sony. otherwise run the file without sonyid in it’s name.


#5

Thanks a lot, I updated the firmware and that worked. However, it still freezes everything when I put a DVD in… any ideas why that is?


#6

bump


#7

when was the last time you installed a fresh OS? maybe there’s a driver problem…
are there nvidia ide drivers installed? what aspi version do you have?


#8

It’s been a while since I installed a fresh OS (to be more specific I’d say a year mabye), however I’ve got a DVD drive installed anyway, which has never had any problems reading DVDs. As for my ASPI version, I checked that info tool, and it says under System ASPI that “ASPI file(s) are missing” however, I do have these:

wnaspi32.dll, version 4.57
aspi32.sys, version 4.57
winaspi.dll, version 4.57

Nero Aspi, however is Winaspi32.dll version 2.0.1.59 and says it’s good.

Also, I checked out my IDE ATA/ATAPI Controllers in dev manager and it’s:

NVIDIA nForce2 ATA Controller (v 2.6)

… so yeah… some sort of evil nVidia spawn of hell…


#9

You really should be using ASPI 4.60 but nForce2 ATA drivers don’t work well with ASPI drivers. Try removing your ASPI drivers using the ASPI 4.60 killaspi batch file here. If that doesn’t work try removing the nForce2 ATA driver and use the Microsoft driver instead.


#10

Well, I updated the ASPI drivers (and tried removing them, too) and neither worked then I removed the nVidia drivers and changed it to “Standard Dual Channel PCI IDE Controller” which worked, to an extent… the DVD drive started working, although Windows wasn’t loading sometimes, and now one of my hard drives seems to have dissapeared… :smiley:
So yeah… new problem with the harddrive dissapearing and all, and I switched back to the nVidia driver to try fix things, although that hasn’t really did anything…


#11

Switch back to the Microsoft IDE driver. Then using Device Manger, delete the secondary channel and then delete the primary channel (in that order). This will then require a reboot. See how things work after this…


#12

Alright, I did that, although it didn’t change anything, it re-detected both channels and now everything is the same as it was before I did it. Also, I think I should mention that I tried going into Disk management to see if I could do anything, and it shows my second drive, and says it’s offline, however if I try to re-activate it I get an error and it just says check system event log for further details. Also, everything says the HD is working alright… despite being completely inaccessible…


#13

I have a problem too :frowning: :frowning: I used to burn a Dual Layer (hope I wrote it correctly :slight_smile: ) DVD and read it.But now it can’t even read it!! I’m sure that there aren’t any problems with the disk that I’ve burned.But I still couldn’t understand why? Is there a problem with my DVD Writer or with my Computer…
Please help me cause a have really important files in that DVD!! :frowning: