Sony DW-D22A

vbimport

#1

Does anyone have the original firmware for this drive? I think it was the BYS2


#2

I do have BYS2. Please send me an email requesting the firmware and I’ll send it to you.


#3

Hi dhc014, i origionally send you the old firmware for this sony D22A drive (BYS1). What has changes in this new version (BYS1) and why isn’t on your site? In fact i cant find it anywhere!

Thanks


#4

I am also looking for BYS2 for my Sony DW-D22A (currently BYS1) but can’t find it.

Will the drive perform better with one of the Lite-On (1633 or 1653) or Sony (710A) firmwares? Would the firmware have to be patched before flashing?


#5

BYS2 has much better media support than BYS1. If I had a Sony DW-D22A, I’d just convert it to a SOHW-1653S.

Attached are OmniPatcher Reports for the two firmwares.

BYS1.txt (11.8 KB)

BYS2.txt (12.8 KB)


#6

Cheers dhc014, next question where can i get it from (the BYS2) and do i need to use a special utility to put it on?


#7

Alright, I’ve been reading a bunch of threads here and it seems like there are 3 options for firmware updates for the DW-D22A.

They are:
Liteon SOHW-1633S firmware update BS0R
DRU-710A firmware
BYS2

Is this correct? And if so, should i just try one, test it, revert back (to BYS1) if i still have issues and move on to the next firmware update??

As for the patchers, i see 2, omniPatcher and LtnFW.
I assume they both work fine and it’s a matter of preference? But please let me know if i should use one over the other.

Thanks for all your help!


#8

Firmwares for the drives that you listed should all work on your drive without any modification by a patcher like OmniPatcher since they are identical in specifications to yours. You could also use a SOHW-1653S firmware on your drive, but it would first need to be patched by OmniPatcher to enable crossflashing since its specifications are different from your drive.

LtnFW is not a patcher, it is a “Flash Tool” which you use to actually put a firmware onto your drive. OmniPatcher just makes modifications to a firmware file on your hard drive.

I’ll try to post BYS2 on my page soon as a binary and as a windows flasher since tons of people are requesting it.


#9

Alright, trying the ones that do not require patching out…all i’m hoping for is a burnt dvd that isn’t littered with bad sectors. I’m using nero’s ‘Verify written data’ checkbox while it’s burning to check the data, since it always says ‘Burn completed sucessfully…’.

Tried:
DRU-710A BYX2 firmware from the codeguys site. Still getting lots of bad sectors :sad:

Yeah, I was one of those people asking for the binary :slight_smile:

BTW, is there anything else that could be causing all these bad sectors rather than just the firmware?? I’ve seen some messages about DMA being turned on, and i checked that on the nero infotool, and it’s on.
Oh, i’m using radius dvd-r discs.


#10

Alright, just finished testing this burner with 2 different firmwares:

Sony DRU-710A BYX2

  • Couldn’t read stuff burnt on the BYS1 firmware
  • Couldn’t read it’s own burnt cd’s!!!
  • Lots of bad sector errors

Liteon SOHW-1633S BS41b
-Was fine reading the BYS1 dvds
-Burn was good all the way up to about 95% where it started having bad sector errors!

Disc used Radius DVD-R OPTODISCR004

Any ideas anyone? Is it time to try and return this thing?


#11

Finally! after getting angry and frustrated i went out and bought some different dvd-r discs.

Came back home, and dhc014 had sent me the drives actual updated firmware BYS2

So i flashed it, and used the new discs, and finally i did not create a coaster!

Not sure if the disc made a difference, i’ll find out soon enough on the next burn. but if the old dvd discs hold up, then it’s the cross flashing that would appear to be the cause!

:confused: was kinda happy about the 4x DL, and 16x -R speed on the new firmwares for the liteon and the sony 710A…oh well hope a new firmware for the D22A comes out that gets it those speeds…

oh, and thanks dhc014, i’m so much happier now :smiley:


#12

You’re welcome.

BYS2 is now on my site for those who want it: http://dhc014.rpc1.org/indexOEM.htm#DW-D22A


#13

cheers dhc014


#14

I have just bought the D22A drive and I’ve faced with BIOS recognizing it as an UDMA drive but Windows XP only recognizing it as a PIO drive.
Have XP updated with SP2 and latest VIA IDE drivers installed. Tested different IDE cabling and still same results.

Drive burns ok but uses 100% CPU as a result of not using UDMA…

I can’t remember which firmware version does it have, but it’s a recent purchase so it’s more than possible that it’s BYS2 revision. I’ll check and confirm, however.

Anyone else having the same problem?


#15

Remove the VIA IDE Drivers.


#16

If you meant uninstalling and reinstalling the drivers, that has already been tried without any result.
If you meant replacing them with another drivers, which drivers should I use?

Thanks for the tip, though.


#17

Hey DHC014, is the BYS3 firmware available at ur site worth the flashing?
What r the improvements it introduces in respect to BYS2?

Thanks.


#18

Finally solved the problem.
It worked by removing the IDE driver and rebooting, but only when I first forced the unit to be in PIO mode.
It seems Windows XP uses a counter when checking device’s capabilities, and that’s the way of making it reset them.

I still have the doubt about BYS3 being worth the flashing, though :wink:


#19

ok. look this answer ===> www.s_wh_sony_dw.i.com


#20

Hey all,

I have a problem relating to this drive too.Don’t think its the same problem as you’re having but perhaps you could throw some light on it for me.

I’ve had this new system for exactly one week and for one reason or another the system would hang resulting in me needing to turn off at the power supply.

Whenever I did this,when booting up the d22a drive would lock up with its light on solid and I would get a “new hardware found” box where the drive wasn’t recognised.Windows also takes much longer to load up when the drive is not working properly.

However,so far the only way to rectify it has been to re-install windows.I haven’t been able to find drivers for it and they’re not on any of the CDs that came with it.

Do you know where I could get the drivers from to save me re-installing windows,and what might be causing this?

Thanks for any guidance.If you need any information let me know.(not really sure what to put - new to all this :stuck_out_tongue: )

Thanks again,
Jason