Sony DW-D22a that no longer reads or writes dvds but CDs are fine

vbimport

#1

Had the Dw-d22a for about 4 months or so. Everything fine, burned dvds successfully - rejected one type of cheap media (but they were so bad that I didn’t think they would work as soon as I opened the packaging). Has worked with Memorex (8x and 4x) DVD+R and DVD-R, Maxell +R (8x), Sony (4x) +R, and another cheap brand which since it doesn’t print the brand on the disc I no longer know what it is. In any case, the drive was working perfectly well and no problems at all (except for WinME’s problem with a 4 GB dvd drive, and some autorun problems). Nevertheless, all of a sudden the drive stopped reading dvd discs of any kind. Either ones it had burned itself or someone elses, or commercial dvd movies, or commercial dvd software discs. On the other hand it works perfectly well as a CD drive and have had no problems of any kind with any cds. Since I bought it to replace my burnt out Cd-rw this doesn’t work for me.

When I insert a cd there is no problem and the system recognizes it without any trouble, but if insert a dvd (+ or -R, blank, burnt, commercial) it spins it for a while then appears to be having trouble spinning it (drive lite is on) and sometimes it spins up to a higher speed (but mostly stays at low spin), and then (after about 60 seconds or so) the drive lite goes off and the drive has decided that there is “no disc inserted”.

I’ve included a nero-info tool report if it’s any help at all.

I need to get this drive back up and running as I’ve got a lot of important experimental data I need to backup,

Any help would be appreciated,

Nero InfoTool 3.01

Drive Information

Drive : SONY DVD RW DW-D22A
Type : DVD±R/RW DL Recorder
Firmware Version : BYS3
Buffer Size : 2 MB
Date : ?
Serial Number
Vendor Specific : Nov17 ,2004
Drive Letter : H:
Location : 0:1
Mechanism : Tray
Read Speed : 48 X
Write Speed : 48 X

Read CD Text : Yes
Return C2 Pointers : Yes
Read CD-R : Yes
Read CD-RW : Yes
Read DVD-ROM : Yes
Read DVD-RAM : No
Read DVD-R : Yes
Read DVD-RW : Yes
Read DVD+R : Yes
Read DVD+RW : Yes
Read DVD+R DL : Yes
Read BD-ROM : No
Read BD-R : No
Read BD-RE : No
Read Digital Audio : Yes
Read CD+G : Yes
Read VideoCD : Yes

Write CD-R : Yes
Write CD-RW : Yes
Write DVD-R : Yes
Write DVD-RW : Yes
Write DVD-R DL : No
Write DVD+R : Yes
Write DVD+RW : Yes
Write DVD+R DL : Yes
Write DVD-RAM : No
Write BD-R : No
Write BD-RE : No
Buffer Underrun Protection : Yes
Mount Rainier : No
Modes : Packet, TAO, DAO, SAO, RAW SAO, RAW DAO, RAW SAO 16, RAW SAO 96, RAW DAO 16, RAW DAO 96

Region Protection Control : RPC II
Region : None
Changes User : 5
Changes Vendor : 4

Disc Information (H:)

Type : - no disc inserted -

Interface Information

Adapter 1

Description : Primary IDE Channel

Driver
Description : ESDI_506.pdr
Company : Microsoft Corporation
Version : 4.90.3000
Description : ESDI_506 Virtual Device (Version 4.0)

Attached Devices
Description : GENERIC IDE DISK TYPE01
Type : Disk Drive
DMA : On

Adapter 2

Description : Secondary IDE Channel

Driver
Description : ESDI_506.pdr
Company : Microsoft Corporation
Version : 4.90.3000
Description : ESDI_506 Virtual Device (Version 4.0)

Attached Devices
Description : GENERIC IDE DISK TYPE80
Type : Disk Drive
DMA : On
Description : SONY DVD RW DW-D22A
Type : CD-Rom Drive
DMA : On
Autorun : On

Software Information

Operating System : Windows ME
DirectX : DirectX 9.0c

Description : Nero Burning ROM
Version : 6, 3, 1, 6
Company : Ahead Software AG
Version Check : Ok

Description : Nero StartSmart
Version : 1, 0, 1, 8
Company : Ahead Software AG

Description : Cover Designer
Version : 2, 3, 0, 5
Company : Ahead Software AG

Description : Nero BackItUp Application
Version : 1, 2, 0, 5
Company : Ahead Software AG

Hardware Information

CPU : Pentium III 800 MHz
Bus Speed : 0 MHz
Motherboard : Intel Whitney System CR Platform
System : Intel Whitney System CR Board
BIOS : Phoenix 6.00
Memory : 256 MB
Sound : AC’97 Sound Card
Video : Intel® 82810 Graphics Controller

ASPI Information

System ASPI : ASPI is installed and working properly

WNASPI32.DLL : 4.71 (0002) 45056 bytes July 17, 2002
APIX.VXD : 4.71 (0002) 23115 bytes July 17, 2002

Nero ASPI : ASPI is installed and working properly

WNASPI32.DLL : 2.0.1.59 160016 bytes December 16, 2003


#2

I’m having a similar problem if not the same problem and running out of ideas. I’ve since bought a new drive, uninstalled all burning and image software. It doesn’t seem to be a windows issue since I can’t even boot from a DVD. I’ve got a brand new Sony DRU-830A that I flashed to make sure it has the latest firmware.

I am still unable to read or write any kind of DVD. I have however noticed one thing. While windows and the bios don’t seem to recognize dvd media. When I tried flashing the drive it did detect that I had media in the drive and opened the tray so that I could remove it.

What could possibly be going on here. I am wondering if I have a bad cable or IDE channel. The drive is currently a primary slave. I will be placing it a USB chassis in abit to see what that brings me for results. Then I’ll try placing it as the secondary master if it works on the USB path. Wish me luck and I’ll post my results.

-Guardian2000


#3

I have had the same problem with 2 LiteOn 20A1P in 6 months period and I’ve RMAd both of them

I believe that the Sony DW-22A is also a LiteOn 16x series , did you by any chance try to set the drive to RPC1 , using LtnRPC utility perhaps ? because each time my LiteOn behaved like his was immediately after using this utility