Sony DW-D22a Problems

Hi, I have a strange problem. This drive worked fine 2 weeks ago, now it takes me an hour and a half to copy a dvd. About 40 mins writing to hdd and about another 40 to burn, often 1 hour.

I have flashed with the 701 firmware, but does not resolve the writing to hdd problem, and makes the burning process longer as the firmware is for 8x.

I have tried other types of media, with no joy, am running out of dvd’s, and patience.

I am copying dvd+r’s, about 4 gig’s each, with a decent computer, I didnt have any of these probs last month. A dvd would take me 10 to write to hdd and 10 to burn.

Any help would be very much appreciated.

Welcome to the Forum, thebeno :slight_smile:

Your Sony is probably running in PIO mode and you’ll have to enable DMA to allow for faster data transfer.

Thanks for your reply Cressida, I have checked that one, unfortunately both were set to DMA and not PIO mode. Any other suggestions would be much appreciated…

Have you double-checked this? Windows can fall back on PIO-mode automatically after a firmware flash or if it detects too many errors in the data transfer. You may want to try a new ribbon cable as well.

Yes, I have double checked. A ribbon cable? As in the one that goes from the motherboard to the drive? Do they deteriorate over time? Thanks again for your help.

So your’e saying DMA is enabled and what is the transfer mode? Also did you install any software or new anti virus or firewalls in the last 2 weeks? If you are using Windows you can do control > alt > delete (opens windows task manager) while doing a burn and see how much CPU usage and memeroy is being used. Might find what’s causing the problem. My anti virus and firewall crap really bog my system down when i leave them on while doing a burn. :iagree: :iagree: :iagree:

Thanks will check that but not installed any other software than Nero which I have always used. It also slows my whole system down to an almost stop. Surfin the internet is almost impossible while burning.

What is your DMA transfer mode under device manager on the IDE channel the burner is on? Are you using the burner as a reader also?

Hi Bryan, yes I am using it as a reader, only have the one drive. How do I find the data transfer mode?

If you are using Windows right click on my computer > properties > hardware > device manager. Then you’ll need to click on the box with the plus in it for IDE ATA/ATAPI controllers then a double click on primary or secondary IDE channel depending which one your drive is on. Then go to advanced settings and you’ll be able to see if DMA is enabled and what the transfer mode is.

Hi Bryan, both are set to DMA if available, and transfer mode is ultra dma mode 5, which unfortunately is like a foreign language to me. Thanks for your help.

Hi! Ultra DMA mode 5 indicates (one of) your hard disk(s). The Sony must be shown as either UDMA2 or UDMA4. Check under both Primary and Secondary IDE Channels. Also make sure not to put your burner and the hard disk that you’re ripping to/burning from on the same IDE Channel.

Yes you are right, the udma5 is the hdd, and my burner shows udma2. They are on different ide cables. Thanks for your help Cressida

Any other ideas guys?

You could try replacing the IDE cable but…i don’t think that’s the problem since it’s in UDMA Mode 2. If you had a bad cable i think it would have switched back to PIO Mode because of errors (but this is a guess). Tell us about your computer. What’s your processor, operating system, anti virus, and how much memeroy you have (important).

Yes, we need more info about your setup, thebeno. Maybe you can attach a Nero InfoTool log?

As suggested by Bryan already, next time you get a slow down like this, look in Task Manager (press Ctrl+Alt+Del) and check which Process is taking up all that power (see screenshot #1).

You can also check your “Burst Rate” in Nero CD-DVD Speed under the Benchmark tab (as a final confirmation that it’s not a data transfer speed problem). Put in a non-empty DVD and press F6 (see screenshot #2)



Thanks for your help again chaps, here goes.

I am using a Dell 2.8ghz, 40gig, win xp, running on the company’s netware novell client, 1014 ram.

Both of the Channels show “Primary IDE Channel” one is set to UDMA5 and the other is set to UDMA2, there is no “Secondaru IDE Channel” showing.

I have just run a benchmark test, is attatched.

Well, something has dropped!! Its now writing to hdd at over 8k kb/s, previously about 2k. Burninig is also faster than before but now only at 8x due to the upgrade in firmware. Surfing is still slow whilst burning, although the task manager shows system idle at 97% and nero 3%, all others are zero.

Are you saying that the hard disk and the burner are shown on the same “Primary IDE Channel”, thebeno? Something like the screenshot below, but showing both devices (hard disk and dvd drive) in the same window? That would explain your problems as sending/receiving data to/from two devices through the same cable at the same time isn’t very efficient. Burner and hard disk should be installed on different channels.

The benchmark results look OK (next time just save the screenshot as a .png image file (with the little floppy icon on top of the window) in stead of pasting it into Word :slight_smile: ). Also, there is a newer firmware available for the Sony 710A (BYX5).